0

I know this question has been asked before, but to no avail, am still not able to export into Photoshop without getting a flattened file.

  1. I released (sequenced) all layers in the file.

  2. Exported the .ai layered file as .psd, with Use All Artboards checked, and with Write layers checked. Before I save, I get a popup that says "Some containers in the .ai file have been flattened".

  3. I open up the file in Photoshop, and sure enough, the entire doc has been flattened".

  4. I even tried not checking the "Use All Artboards" box.

Please help, what am i doing wrong?

12
  • You must not use any transparency or blending modes. Using either will flatten AI layers. – Scott Feb 28 '20 at 22:33
  • Would having a few transparency layers really cause the entire document to be flattened though? I was able to test this process earlier, and MOST of the layers exported. Just not all of them. (scratching my head) – Leonor Feb 28 '20 at 22:38
  • Yes. Generally anything with transparency and below it will be flattened. – Scott Feb 28 '20 at 22:45
  • So as a test, I eliminated object with any transparency or gradient. But those objects are still flattening even though they are the top layers in the documents. Thinking I may have to purchase a smart layer plugin. – Leonor Feb 28 '20 at 22:53
  • Be aware, glows, blurs, drop shadows, etc. will create transparency as well. Basically it comes down to the Appearance settings. Some appearance items cause what is below them to be flattened in order to maintain the overall visual appearance. – Scott Feb 28 '20 at 22:59
1

You must remove all transparency before exporting.

This includes glows, drops shadows, blurs, any blending modes, opacity, etc. Anything which introduces transparency will cause all layers below it to flatten in order to maintain the visual appearance.

In addition, always export to the same color mode as the AI file. RGB to RGB and CMYK to CMYK. Never try and cross color modes with the export. (You can always change the mode in Photoshop once you get a good export)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.