0

Following this explanation to scale a pattern down in Illustrator 2020 doesn't seem to work.

To reproduce: Create a New Document, draw a Shape, apply a Fill color, select a Graphic style, right-click the Object, Select Transform, then Scale, uncheck everything except Transform Pattern, chose a value.

Nothing seems to happen. Alternatively it's impossible to click "Transform Pattern" without "Transform Object" becoming ticked automatically (I don't want to scale the object, just the Pattern).

I've been using Illustrator for 20 years now, so it's either a new bug or I'm missing something obvious.

enter image description here

  • The alternate "ticking" of "object" or "pattern" is standard. One of those options must be ticked. I can't test CC2020... but based on your gif.. it does look broken. (Works as expected in CS6 and CC 2017). If you use the Scale Tool, and hold down the ~ (tilde) key while dragging... will the pattern scale then? – Scott Mar 24 at 21:52
  • I don't think it's standard for a box to become ticked when you click another box. The point of using boxes that can be checked is so that they can be checked independently (otherwise they'd use a radio button or a dropdown,,, or explain why the other one gets checked). When I apply a texture to a shape and then select the "Scale" tool, the box around the object disappears and only anchor points appear (left right top and down of the circle). These cannot be dragged. – MicroMachine Mar 24 at 22:13
  • The checkbox toggling is how AI has always worked. Radio buttons wouldn't work because you can have both checked - radio buttons wouldn't allow that. What if you drag with the Scale tool and Tilde key depressed? – Scott Mar 24 at 22:44
  • Selecting the Scale tool is enough to make the box around the circle with the handles disappear . Here's a screencap showing the normal "Selection Tool" box around the object, then the box disappearing when Scale Tool is clicked, allowing only to drag anchor points (non proportionately to the shape obviously) and at the very end dragging an anchor point in Scale Tool mode with tilde key pressed, even more useless. – MicroMachine Mar 24 at 23:46
  • 1
    Then yes, it appears broken. The Scale Tool with the Tilde key depressed should scale the pattern and not the object (clicking anchors and the bounding box are irrelevant) – Scott Mar 24 at 23:50
1

You have applied a Graphic Style (confusingly called Vonster Pattern Styles) rather than a Pattern Fill Swatch- In your gif it looks like you go to Window> Graphic Styles Libraries> Vonster Pattern Styles to make your fill choice- to be able to scale the pattern fill you will need to have a Pattern Fill Swatch chosen from the Swatch Library> Patterns> Decorative> Vonster Patterns

| improve this answer | |
  • He's simply using an external library swatch, not a graphic style. It shouldn't matter. – Scott Mar 25 at 5:58
  • 1
    @Scott- I think he went to Graphics Styles Libraries (accidentally I would guess) instead of Swatch Libraries- I tried that with same results he is having- it is not scalable- his gif goes fast and is cut off at the bottom but the list it shows of the Graphics Styles Libraries matches the list mine shows- I am fine to be incorrect but I think I am not – Kyle Mar 25 at 6:56
  • 1
    @Kyle Hmmm . . . I just tried the graphic styles vonster pattern, and it seems to scale as expected, the same as an ordinary pattern. I'm still using Illustrator CC 22.1 (2018) in Windows. Perhaps this is a bug in an older/newer/Mac version of Illustrator? – Billy Kerr Mar 25 at 9:00
  • 2
    @Billy Kerr- very interesting.... I am on a mac with Illustrator 24.0.3 (2020) and it is exactly the same as the issue asked about here- object will scale but the pattern will not scale separately if the pattern comes from the Graphic Styles Library. The pattern will scale fine if chosen from the Swatch Library- I just opened Illustrator 22.1 (2018) on my mac and it behaves the same- no scaling- I guess it is a mac bug then... – Kyle Mar 25 at 15:26
  • FYI. it wouldn't be the first time pattern scaling was an issue. Somewhere around CC2014 pattern scaling would vanish/reset if you copied a pattern-filled object to a new file. – Scott Mar 25 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.