I used to edit and sign pdf forms using Inkscape 0.91 on Ubuntu. For the past 2 weeks, I have been unable to do it.

I can import and embed pdf files in Inkscape, add text and paths, but when exporting, only the original embedded image would show.

I then tried to boil this down to a minimal example. Opened an empty file, wrote some text, exported it as pdf. All it did was creating a blank pdf file.

I tried to export with different options, tried to "print to file", moved elements to a new layer and even opened the pdf with a different pdf reader (evince and okular). Nothing works.

What can have gone wrong?


Here is the options menu I get when exporting through file > save as

enter image description here

  • 1
    Hi. Welcome to GDSE. Unfortunately I can't replicate this problem. PDFs save just fine in Inkscape 0.92. Make sure you are using the latest version of Inkscape.
    – Billy Kerr
    Mar 26, 2020 at 15:33
  • 1
    IMHO, the latest LTS version of Ubuntu is 18.04, where Inkscape 0.92 is the current version. Maybe you can update your system. Mar 27, 2020 at 17:22

1 Answer 1


I'm unsure exactly how you are exporting as PDF, but I found a possible issue you might have with the text.

This is how I export the file file -> Save as -> Change type to PDF -> Check options -> OK Options for PDF export

You can check in case you selected Omit text in PDF and create a LaTeX file option, in which case you won't get the text in the saved PDF

I'm using Inkscape 0.92 on Windows.

PS: With incomplete information about the question, I'm unsure if this answer is useful. I was going to post this as a comment but don't have enough reputation. You might find some useful answer here

  • Thanks Prashant! I export the way you do, but I have no such option in the menu. I'll edit my question to add info. Mar 26, 2020 at 21:19
  • I also got it to work in 0.92.4 in Ubuntu. Did you try updating your version? Apr 4, 2020 at 4:33
  • No, I can't upgrade to 18.04 because I mixed up things with virtualenv. I'll have to reinstall ubuntu, I'll let you know if it worked when I have. Apr 7, 2020 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.