I am trying to cut up a circle into several smaller rings, I am using a quick method I where i go to the Select menu option and choose Modify > Contract. Using this sparingly like 5px, the object is still rounded to the average viewer.

However, if I increase the amount to contract the shape by. Up to say 45px, the image becomes blocky as shown below (B). It goes from being a perfect circle (A) to a somewhat rounded polygon and it gets even worse the more I increase the pixels to contract by. Is there any explanation for this behaviour? The shape is rasterized.

enter image description here

  • It looks to me that the selection is vector based and when you modify the selection, it takes the average of the distance from each point to the nearest node in the vector path. And this path is then converted back to pixels which results in a distorted circle. Dec 23, 2012 at 9:19
  • the selection is vector based but it doesn't operate on vector objects.. odd.
    – user9112
    Dec 23, 2012 at 9:23

3 Answers 3



Flatness of an arc (or circle) determines the number of points needed along the arch to create a visually smooth curve. With things like circular selections, what is really created is a series of straight lines between points. The more points, the more straight lines there are. When the number of points reaches a visual tolerance, the straight paths visually appear to be an arc. However, it is still a series of tiny straight paths.

Some aspects of digital reproduction can not draw curves. Not even one. So the flatness setting is used and determines the number of these points and straight paths needed to draw a curve. Things like laser printers, imagesetters, and other output devices all use a flatness setting to produce visually smooth curves. Photoshop's selection tools use flatness as well.

When you contract a circular selection, you are asking Photoshop to remove points along the arcs. The more you contract, the more points you remove. Eventually you can remove so many points that the appearance of smooth arcs is lost and you end up with what you see in your example. If there were a direct method for adjusting the flatness settings for Photoshop's tools (there isn't) you could lower the flatness setting and see this effect on all curves, not simply contracted curves.

Many software applications used to have an adjustable flatness preferences. But with the increased performance of software, most flatness adjustments are done directly in the output device or in its settings rather than the applications themselves. It was one of those preferences users didn't fully understand but could absolutely wreak havoc on artwork if it were played with. It was probably best the developers removed those preferences so users can't improperly set them within the applications.

There is still one area in Photoshop where you can adjust flatness, clipping paths.

clipping path.

Of course, you never want to put a value in that field unless you know the proper flatness setting you need to alter your clipping path. If you do not use a value, then the path uses the output device settings for flatness, which is preferred). On screen, you'll see no visible change when applying a flatness setting. You only see the change upon output, which is why it can be a dangerous setting.


Your method won't work. It doesn't contract smoothly. You'll have to go the long way around.

1) Draw your largest circle on the first layer by holding shift and dragging the elliptical tool.

2) Fill the circle, then hit CTRL+J to create a new layer with that shape. Go to Edit>Transform>Scale and reduce the size of the new layer by whatever percentage you need to. Fill the new layer.

3) Rinse and repeat until you end up with the number of concentric circles you need.


Here is a quick tutorial on how to get around this problem. https://www.youtube.com/watch?v=_CvDj8PaGv0&feature=youtu.be

  • Hi Andrew, could you please explain a bit more what we'll find behind the link you provide and why it answers the question? That way, your answer is still of value in case the link breaks at a later time. Link rot is the main reason we really dislike link-only answers here. Thanks for your effort and keep contributing!
    – Vincent
    Dec 10, 2014 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.