I have what seems like it should be a very simple problem in Illustrator, but I can't figure out how to do it. I am trying to combine two non-overlapping shapes so they share the same stroke. Piece of cake in Photoshop, absolute nightmare in Illustrator. Here's an example of how it should look:

Outline example correct

And here's what happens in Illustrator:

Outline example incorrect

I've tried all the options in the Pathfinder as well as trying to combine through Object -- Path and Object -- Shape to no avail. Seems like this should be really easy... what am I missing?


Thank you for reply, Scott! Unfortunately, that isn't working for me for some reason. I have grouped the elements, but I do not see what you showed in the Appearance panel. Here's what I see when the elements are grouped and selected:

Illustrator Screenshot 1

If I open CONTENTS, I see this. Moving the STROKE layer below FILL doesn't help.:

Illustrator Screenshot 2

This is only an issue where I cannot use the Pathfinder to merge elements because they do not overlap. Sorry I'm not getting this. Any thoughts on the issue?

Thanks again!

  • Protip: disable the properties panel/assets/Library panel they just use your screen estate then enable the control bar. It does the same in much more compact form, and now you can finally learn illustrator. (adobe tries to market its own new features but yo can not understand illustrator if you use these features, sice they are mostly useless for you next 3 years of learning) – joojaa Apr 9 at 14:24

Convert the shapes to a compound path. Select all of the objects you want that affect, then from the Object menu, select Compound Path... Make. (Ctrl+8) This should take care of your issue.

| improve this answer | |
  • Ctrl+8 -- I knew it had to be something easy. Worked like a charm, THANK YOU SO MUCH! – Jim Apr 9 at 14:56
  • 1
    @Jim If you ever need to change colors of individual letters you will be happier grouping. – joojaa Apr 9 at 15:37

Group the black elements.

Using the Appearance Panel add the red stroke and move it below the Contents in the panel.

enter image description here

| improve this answer | |
  • Thanks, @scott! I can't seem to include screenshots here, so additional question below original. – Jim Apr 9 at 12:51
  • 1
    @Jim dont drill into the group apply on group upper level. If you look carefully it reads group no appearance. Delete the red lines and click on thegroup no appearance (or select again) – joojaa Apr 9 at 14:22
  • @Jim I posted to move the stroke below the Contents, not the fill. Please look at my image of the Appearance Panel carefully. You don't need a compound shape and in some cases a compound shape may cause other issues. For example, in my image, if the black were a compound shape the overlap of the P and the bar would reverse and be a hole. – Scott Apr 9 at 18:36
  • The compound path route is the only thing that works (but I take your point about the overlap). There is no option to "open" the GROUP to display FILL and STROKE. Clicking on it does nothing. Double-clicking does nothing. Only double-clicking the CONTENTS option shows FILL and STROKE, but neither of them let me move them outside CONTENTS. Selecting GROUP before adding the stroke doesn't work, the stroke is added in the CONTENTS area. The only thing I can do is change the order of FILL and STROKE in CONTENTS. I don't have the options I see in your screenshot. Thanks again for trying to help! – Jim Apr 10 at 13:49
  • @Jim... no no no... You don't click Contents. Simply add a new stroke with the group selected, then move that new stroke below Contents. By double-clicking Contents you are diving into the group not adding the stroke outside the group itself. Again, if you look at the Appearance panel in my image, you see it's the group, not the contents of the group. – Scott Apr 10 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.