1

I draw a lot on photoshop but often use the selection tool to select parts of my drawing and rotate/resize parts as I go along. Until a few days ago I used to use Photoshop CC 2014 and had no problems doing this. What used to happen was that I would use the selection tool, rotate/resize the selection, notice that the transformed part looked pixellated but I knew that once I hit 'enter' all the pixellated edges would immediately 'smooth' out so it was no problem.

However, this 2020 version no longer 'smoothes' out the edges once I hit 'enter'. I've been messing with the interpolation settings to try and overcome this but I see no difference. I know that this must be possible to achieve since it is something that used to happen in the 2014 version. It's probably some small setting which I have forgotten to enable. However, most of my settings got transferred from the previous version so I am pretty clueless as to how this has happened. Anti-aliasing on my selection tool is currently enabled.

Attached are screenshots of an example and my settings to help illustrate what happens (unfortunately I no longer have access to the 2014 version so I cannot show you a comparison of what used to happen).

I am new to posting here so any help would be much appreciated! Thank you!

(At 98% zoom) example at 98% zoom

Settings: settings 1 settings 2

  • Check whether 'anti-alias' is ticked , up top in the control bar, while you are doing the transformation? – Vincent Apr 17 at 11:51
  • Set your zoom to 100%. Don't zoom in on raster images!!!! – Billy Kerr Apr 17 at 12:03
  • My zoom in the picture above was at 98% as I posted. I just used a very thick line to illustrate what I meant. Zooming was not the issue and one which I was tired of seeing on other forums! I have posted the solution which solved my problem below. – Simone Apr 17 at 12:09
  • Maybe so, but 98% is enough to cause problems that aren't actually there. Raster images should always be viewed at 100% on screen - i.e. when pixels on a computer screen map at a 1:1 ratio with the pixels of the image. There are so many questions here on GDSE where this topic comes up again and again. – Billy Kerr Apr 17 at 12:13
  • I understand what you're trying to say but as I have been drawing on photoshop for a number of years where I regularly zoom in and out while working on details, I know that the extent of that pixellation should not be happening purely due a zoom issue. It was just frustrating me that whenever I tried to search for an answer to my question it was dismissed by zoom responses whereas my solution was never once mentioned. Since I had used the 2014 version, I have the advantage of experience to be able to know 100% that this was not a zoom issue. – Simone Apr 17 at 12:41
2

Fixed it! Posting the solution in case it helps anyone else.

Tried enabling anti-alias on the transform tool but realised there was no such box on the control bar (it's only on the select tool) as Vincent posted.

BUT while doing that I noticed another option pop up on the control bar while transforming! A separate option to adjust interpolation appears once you rotate an object. This was originally set to nearest neighbour but once I changed it to bicubic smoother all was sorted as it did before! Amazing!

Attached is the setting in case it helps anyone (it's on the far right). Once you click enter the transformed selection smoothes back to its lovely form. Happy days!

enter image description here

| improve this answer | |
  • I tried that before but it says I have to wait 2 days to accept my own answer so i have 22 hours to go unfortunately – Simone Apr 18 at 12:58
  • OK. I'll remove my unnecessary comments. – user287001 Apr 18 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.