0

I'm running Inkscape 0.92.4 on Ubuntu Linux 19.10. My graphics driver is from NVidia. I'm given to believe that Inkscape's filters should work and render fairly similarly to how filters work in GIMP. My expectations are based on this image which shows various filter effects which ship with Inkscape:

enter image description here

However, when I apply filters to even very simple shapes, I get horrible pixelated garbage like this:

enter image description here enter image description here enter image description here

Can anyone help me understand what is wrong and how to correct it? Thanks!

0

It looks like you have zoomed in by over 500%. You can't zoom in on SVG effects, because they are rendered as raster images. Raster images are made of pixels, so if you zoom in you will see horrible pixelization.

Instead, make your artwork bigger, apply filters to objects and view them at reasonable zoom levels like 100% or less.

Also make sure to set Preferences > Rendering > Filter Effects Quailty for Display to "Best Quality (slowest)". Also note that this may considerably slow down the refresh if you zoom in on images, so you may not want to engage that setting until you have created the artwork.

You also need to be aware that excessive use of filters in SVGs can slow down rendering in browsers, and in some cases certain effects may not render as you expect, depending on the browser.

These examples below are at 100% zoom. These are the first 6 effects listed under Bevels.

enter image description here

| improve this answer | |
  • I'm not an Inkscape user. Does this also answer this, this and this question? – Wolff Apr 28 at 23:56
  • @Wolff yeah these look like the same issue, although I can't see the zoom levels in the other questions like I can see it in the OP's examples here. – Billy Kerr Apr 29 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.