I have created a shape and selected a layer. In the Edit menu the Define custom shape... option is disabled.

Can any one tell what mistake I have made.

enter image description here

  • 1
    Need more info. How did you "create a shape"? What tools did you use? Did you try selecting the path with the Selection tool first? – Scott Dec 27 '12 at 12:14
  • i had used pentool to draw a shape...ya i tried pathselection also,,but define custom shape is in disable state only – Rachuru Dec 27 '12 at 12:38
  • Is the path highlighted in the Path Panel? The path must be highlighted there to define a custom shape. – Scott Dec 27 '12 at 12:39
  • yes path is highlighted only,,,,but i dont know where i am doing mistake. – Rachuru Dec 27 '12 at 12:50
  • It looks like you did it correct. Check on the layers palette and click on the right side square thing, it should change to have white around it although it looks like it does in your screenshot. Otherwise going off your screenshot everything looks correct so if thats not it the problem isn't in your screenshot so will be very hard for us to answer. – Ryan Dec 27 '12 at 18:43

Select the path on the canvas with the Direct Selection Tool (white arrow). Define Custom Shape should activate for you then.

enter image description here

  • i tried this but not getting – Rachuru Dec 28 '12 at 6:18
  • Try performing the same steps in a fresh file. If that still doesn't work, I'm afraid something is broken with your copy of Pshop then. Time to start the hunt for corruption. – plainclothes Dec 28 '12 at 23:59

You need to create a "Shape layer" or "Work path" to be able to define a custom shape.

1) As first click on rectangle tool and then on shape layers selector

enter image description here enter image description here

2) After that draw a new layer and click with a right mouse button on that layer. You will see "Define Custom shape" option

enter image description here

3) Or you can create a new layer with a pen tool

enter image description here

4) And then take a "Path selection tool" and right-click this layer

enter image description here

  • i tried like this but Define Custom Shape is in disable stare only....i dont know were i am making mistake – Rachuru Dec 27 '12 at 13:09

I was running into the same issue. I solved it by allowing all shapes to be loaded within the shapes. Right after that I was able to define my shape.

enter image description here


You have too many shapes delete some it will get activated.

Did this happen to me recently, it took me a long time to figure out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.