1

I' m looking for a way to make sure that the .dxf export doesn't include elements outside of a mask.

If such a function exists, it would be the simplest, otherwise you have to remove the mask and all the curves it hides (if you have a solution to do this quickly, I'm also interested).

Original file, with the wanted visual for export: Original file, with the wanted visual for export

Same file with realeased mask: Same file with realeased mask

After exporting drawing WITH the mask in.dxf,, open in LibreCAD: After exporting in.dxf, open in LibreCAD

  • Indeed I would rather keep strokes, otherwise another problem will occur when I will import the .dxf in RDWorks (for laser cutting) – Mushu May 8 at 14:51
  • No lasers do not understand clipping paths you must make all of this real. – joojaa May 8 at 15:20
  • In LibreCAD many useful curve editing tools do not work with imported curves. The questioner cannot trim the tails off in LibreCAD. I have tested and seen the same in other free and low cost CAD programs, too. Some of them allow trimming if the DXF export in Inkscape is set to export curves as polylines. I guess all cutters do not love numerous of corners per a curve. LibreCAD disables edits, no matter does the DXF from Inkscape contain polylines or splines. But user Billy Kerr has shown how to remove tails in Inkscape without converting strokes to paths nor generating duplicates – user287001 May 8 at 20:18
2

This can be done in Inkscape relatively easily, and the following method is similar to how the Shape Builder tool works in Adobe Illustrator.

  1. Make sure everything is ungrouped, and there is no clipping mask just a regular circle instead to be used to cut everything out.

  2. Make a combined path of the drawing plus the circle, by using Path > Combine Ctrl/Command+K.

  3. Draw a large filled rectangle, move it under the combined paths using Object > Lower to bottom End.

This example below shows the combined paths filled grey, and the large rectangle filled red.

enter image description here

  1. Select everything, then do Path > Division Ctrl/Command+K. The result will divide everything into separate pieces. Select and delete all the pieces outside cutting circle.

enter image description here

  1. Finally remove the fill.

enter image description here

If your laser cutter requires one path, you could select all and combine the paths again. Not entirely sure if it will give you the result you want, but I suppose there's no harm trying. Also note that you may have to deal with the text items separately.

Edit: Option 2

Here's a slightly different approach which keeps the lines and circles as complete paths instead of separate shapes,

  1. Combine the drawing paths, but keep the circle as a separate path on top

  2. Copy the circle (you''ll need this later)

  3. Select both combined path and circle, and do Path > Cut.

  4. Do Edit > Paste in Place to bring back the circle which was be consumed in the boolean operation.

  5. Select and delete all the paths that lay outside the circle.

Example

enter image description here

| improve this answer | |
  • The questioner attempts to laser cut some tool or decorative stuff by having circles and non-duplicated open paths which are generated with some parametric curve family formula in plane. I guess it belongs to microwave engineering. But the essential thing is they are circles and open non-duplicated paths. How to work in that case.? I would also use it if I knew it. – user287001 May 8 at 15:32
  • Yes, exactly. The drawing is extracted from Astrolabe Generator with the help of a .eps file. I don't know exactly how the shapes are generated, but indeed it's just about circles and paths and I would like to keep it that way for laser cutting. Otherwise it's possible to combine every elements, no fill, just stroke, but it's overlapping. Not good (but working) for laser cutter – Mushu May 8 at 15:46
  • @Mushu I've edited my answer to give you another method which might be better. – Billy Kerr May 8 at 16:58
  • @user287001 see my edit – Billy Kerr May 8 at 17:00
  • Great! Thanks a lot @BillyKerr! It's exactly what I was looking for – Mushu May 8 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.