1

I am trying to place an .ai file containing Opacity Masks into InDesign. However, in InDesign the Opacity Masks are not displayed as intended. Any ideas or checkboxes I might have missed?

Here's the object in Illustrator: (its a simple red square with the "stamp border" outline that is clipped via opacity mask)

the Illustrator view

And this is what the placed .ai file looks like in InDesign:

the InDesign view


I know that there are ways of constructing the stamp shape in Illustrator without using Opacity Masks – I would prefer to keep the edges live though, to be able to edit the "cutout"-radius.


Any pointers in the right direction are greatly appreciated.

8
  • Instead of copy pasting, try saving the AI file, and then place it in InDesign.
    – Billy Kerr
    May 12 '20 at 14:01
  • thank you for the reply @BillyKerr, I am actually placing the file. (as copy-pasting is not an option in this scenario since the stamps will be filled with detailed graphic elements)
    – dom
    May 12 '20 at 14:05
  • in your question it says "And this is what the pasted .ai file looks like".
    – Billy Kerr
    May 12 '20 at 14:08
  • thanks for pointing that out. corrected.
    – dom
    May 12 '20 at 16:30
  • 1
    If you export the .indd as a .pdf or .jpg, does the effect show up again? It might just be that InDesign's preview function can't handle the mask but it exports it properly.
    – Vincent
    May 12 '20 at 16:33
2

This probably due to InDesign's preview function for vector files being shoddy rather than an error in your file. Try and export a .pdf or .jpg from your InDesign file and see whether the effect shows up in there.

0

I had the same problem and I found that using a linked file for the mask does not work. However if you embed the mask image in the the AI file, itt works OK, InDesign recocnizes the mask.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.