I've installed Gimp to do a very simple pixelated effect on images. Now, it IS satisfying in the Gimp interface, but whenever I export it to PNG, I get an ugly faux-pixel result. Any idea where this could be coming from? (It should be noted that I am a total neophyte in graphic design.)

The pixel effect was done by selecting the layer and then going into Filters > Blur > Pixelation. I have taken the original image from a random website and just copy-pasted the logo in a separate file, then applied the filter.

Here is a OneDrive link to the xcf file: xcf file

Here is an example in Gimp with the Fallout 76 logo:

Good pixellation

And here is the same image exported in PNG:

Bad pixellation

  • Hi. Welcome to GDSE. I can replicate the issue. What is the image mode of the PNG? How did you make the pixel effect. What are your export settings? Perhaps consider sharing the XCF file. Please edit your question and provide more information. Thanks.
    – Billy Kerr
    May 27, 2020 at 8:37
  • Thank you - I added some info and a link to the xcf file, hopefully it is enough. I'm not sure where to check the image mode of the PNG? It should also be noted that exporting to jpg yields the same result. My interface is in French so I'm not sure the export settings would be very legible.
    – ledebutant
    May 27, 2020 at 8:57
  • 1
    The XCF is in Indexed mode. Click Image > Mode > RGB. Then it will work.
    – Billy Kerr
    May 27, 2020 at 9:00
  • Thank you very much! I would have never found it by myself...
    – ledebutant
    May 27, 2020 at 9:03
  • I've added an answer now.
    – Billy Kerr
    May 27, 2020 at 9:26

1 Answer 1


The XCF is in Indexed colour mode.

To fix it, click Image > Mode > RGB. Now when you export the PNG, it will work as expected.

When you open an image from the web in GIMP, especially PNG or GIF images, it's always good to check the image mode. Convert to RGB first before editing, especially if you intend to use filters or edit the colours of an image. Note also that many of the legacy filters won't work in Indexed colour mode.

The reason for this is that in Indexed colour, the number of colours is restricted to a limited palette of colours which could be anything from 256 to just 2 colours. To be able to edit the image properly it should be in RGB mode so the full range of colours is available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.