0

I'm presently having a Spider-man experience with InkScape 1.0 (4035a4fb49, 2020-05-01).

The initial files are straightforward SVG files, with none of the settings or superfluous stuff that Inkscape insists on using, as a simple example:

<svg 
   xmlns:svg="http://www.w3.org/2000/svg" 
   xmlns="http://www.w3.org/2000/svg" 
   viewBox="0 0 4200 260" 
   height="75" 
   width="1211.538">
   <path 
      d="m 190,0 
         c -660,0 -1290,0 -1990,0 0,87 0,170 0,260 600,0 1220,0 1837,0 
         C 100,180 160,96 190,0 
         Z" 
      style="fill:#f77;fill-opacity:0.32;" />
    <path 
      d="m 230,260 
         c 720,0 1470,0 2170,0 0,-90 0,-173 0,-260 
         C 1600,0 800,0.01 0,0.01 63,97 140,180 230,260 
         Z" 
      style="display:inline;fill:#f7f;fill-opacity:0.32;" />
</svg>

What I'm trying to do is to move the images into the viewport fully, without having to translate the position (as is usually done with InkScape).

The problems I'm experiencing are:

  • When I ungroup a grouped object, or attempt to move multiple objects, it tries to apply its own styles, colours, and even its own curves to a paths
  • When I Resize page to drawing or selection, the objects are 'transformed (translate)' onto the page, rather than their co-ordinates adjusted

As an example, here's a simple pair of shapes that I'm trying to move...

Current image status

In the image above, you can clearly see that the page boundary lies over the top of the shapes.

Notice the curves and colours on the cross-over in the middle...

Cross-over section

Now, if I apply the Resize to the page...

After the resize

The objects change shape in the middle. As this is part of a corporate identity design, I can't have this happen; I suspect that InkScape is recalculating (badly/bugly) the bezier curves used in the two paths.

I did check to see if this was a bug, but couldn't find anything directly.

Are there options (I've looked, searched with Google, and even tried swearing harshly at my PC, but I can't find anything) to turn these incredibly annoying features off, or a simple way to achieve my goal without having to manually recalculate all of the values?

0

You can switch off the transform behaviour in Preferences > Behaviour > Transforms, and choose "Optimise" instead of "Preserve".

However if you then move paths, Inkscape will recalculate the path positions, and add its own styles. I know of no way to prevent that. However, when I do this the shapes and curves do not change visually. I can't replicate that part of your problem.

| improve this answer | |
  • Hmm... I did check that setting, and it is set to optimise already. I'm suspecting that this could be a bug with InkScape. Thanks for your time, Billy. – Paul Jun 15 at 14:39
  • @Paul - I'm using Inkscape 1.0, and it seems to work without any problems. – Billy Kerr Jun 15 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.