3

I have created the plot below using R and exported the figure as a PDF-file. I would like to add additional elements to the plot, and I typically use Illustrator 2020 for such jobs.

Original R plot

However, when I open the PDF-file in Illustrator the points (the cirles) are turned into small squares with a cross inside (I have enlarged on point so it is easier to see). If I make the plot in R with squares instead I do not have the problem. PDF opened in Illustrator

Does anyone know how to fix it?

The PDF-fil can be downloaded here: https://github.com/PDRohde/illustrator_problem

Cheers Palle

4
  • Checked your file. The circles are indeed 100% gone and replaced with text boxes for some reason. You probably need to experiment and adjust your code.
    – Lucian
    Jun 19 '20 at 12:29
  • Thanks - it is strange because it is only for some symbols that I get this problem. Triangles dosen't work, but diamonds and squares does :) Jun 19 '20 at 12:37
  • Make sure you're not placing TEXT symbols, but use actual circle shapes instead. That could be it.
    – Lucian
    Jun 19 '20 at 12:45
  • The box with an X through it indicates a missing glyph in a font. When you output the PDF, do you have an option in R that can convert text to outlines? I've never used that software so I don't know if it's possible.
    – Billy Kerr
    Jun 19 '20 at 12:48
1

Since I was beaten to the better answer I will offer an alternative :)

In this case, you can also resolve within Acrobat Pro if you have it.

First, change the font of the circles. This can be achieved with Edit PDF. Change them to a common font or one installed on your system like Arial. In this case I just dragged a box over all the circles and changed the font en masse. If you have add-ons like PitStop Pro, then there will be tools that replace fonts en masse more easily.

Next convert the font to outline via Preflight. This tool can be found under Print Production. Just type outline font, and it will appear on the list. This function will make you save the PDF as a new file.

Open the .PDF in illustrator, and it should have the circles intact. There is a drawback and that is the text around the axis and the legend will also be outlined. However, you can easily re-type or just pull from the original version.

3

A guess: The circles are actually pieces of text. The font is included to the PDF, and it's available for the PDF reader, but Illustrator refuses to read it because Adobe doesn't help uncontrolled font distributing. You would have a theoretical possibility to write something without paying for a font.

Try to open the PDF in Inkscape. Import can work because Inkscape isn't font seller. The unfortunate thing in Inkscape's PDF imports is unpredictable deep multilevel groupings. You may need to apply Ungroup several times or to apply extension Deep Ungroup.

Maybe you can insert a link to the PDF to stop guesses and to get some reasoned help. Use a cloud which doesn't need login.

ADD after the link was made available: The guess was right, the dots are pieces of writing.

I released in Illustrator the clipping mask, selected one of the dots, then selected all of them by applying Select > Same > Appearance. Applying Type > Font > Arial restored the circles. In the next image only a part of the texts is changed to Arial:

enter image description here

When editing PDFs in Illustrator you may need to release and delete numerous clipping masks before you can select the wanted objects. This case needed only 2.

How do I know Arial is the right choice? I don't. It was only a guess. Illustrator tells when you open a PDF what's missing and Acrobat can give also a list of needed fonts. The original is the original. I tried also Windings as a substitute. It seemed to work, too.

In this case Illustrator said

The font AdobePiStd is missing. Affected text will be displayed using a substitute font.

Tried also Inkscape 1.0. It imported the PDF. Import mode "Internal" worked, Poppler-Cairo import didn't.

2
  • Thanks for the suggestion! And have updated my question with link to the file. Jun 19 '20 at 12:24
  • Amazing - it worked! Thanks Jun 22 '20 at 7:10
2

I was creating plots in R with ggplots and faced the same problem (circles into squires). The suggested solution did not work for me, but a very easy one that worked was to change the transparency of the dots (for example alpha=0.2). Afterwards, AI does not read circles as text anymore and they are shown correctly! This solution is so fast and easy, that I thought it may one day be of use to someone. illustration

0

Make sure you're not placing TEXT symbols, but use actual circle shapes instead.

Otherwise, the circles may still be there, but may have been enclosed into rectangular clipping masks and turned the fills into outlines.

This kind of thing happens sometimes when importing work generated from other software into AI.

What you can do is hit CTRL+Y which switches to outline view, which is a shape-only view with no formatting shown, at which point you're probably going to see the circles again.

If so, then hit A and start manually removing the rectangular shapes around your circles — there are different ways of doing this.

If you don't see the circles in CTRL+Y mode, these may have just been converted to squares on import. Play around with the R to PDF options, see if it can produce different types of PDF — yes, there are multiple kinds of PDF and AI could differentiate between these on import.

Also try exporting to SVG. Its a try until it works thing.

2
  • Thanks for your suggestions, Lucian. Unfortunately it is the same; just in black ;) Jun 19 '20 at 12:04
  • Updated my answer with more suggestions.
    – Lucian
    Jun 19 '20 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.