0

Whenever I copy something from Illustrator and paste it into Photoshop as a smart object, the shadows always become weird looking and I don't know how to fix that.

Illustrator (original project):

enter image description here

Photoshop:

enter image description here

I've been researching this for a while but haven't found a solution because I mostly don't understand some of the terms and tricks that are posted. I have zero experience with Illustrator, but I can work with Photoshop a bit and that's why I want to move those AI projects (that I buy ready-made) to Photoshop so I can work with it.

Everything has been working out flawlessly for me doing it this way, except when I come across shadows!

2
  • You can not have multiple different blending modes in one object – joojaa Jul 30 '20 at 16:21
  • What format are the files you bought? EPS? AI? – Billy Kerr Jul 30 '20 at 17:23
1

Change how the shadows are structured.

Use transparency rather than blending modes.

enter image description here

enter image description here

Note that when using transparency you want both color stops to be the same color. This will help control the drop off within the gradient.

This does slightly alter appearance on a background since there's no blending mode at play. If the blending is imperative, import your shadows to Photoshop as separate objects. You can then reassign a blending mode there.


Disclosure.... I am a bit "old school" and do my level best to avoid ever using any blending mode within Illustrator. Or I flatten the artwork/objects after using a blending mode option.


You can also merely remove the shadows in Illustrator and recreate them in Photoshop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.