1

My question is different than this question.

I have created a design with blended lines:

enter image description here

And now I would like each of the intermediate steps between the two base strokes to become a stroke as well.

"Flatten transparency" doesn't work, because it only converts some lines, and it converts them to outlines so I have two strokes around each line instead of one:

enter image description here

"Expand" is not an option (because CS6?).

And "Expand Appearance" doesn't work either, because it does this:

enter image description here

Since I am creating a Blend between two Strokes, I would very much like the result to be two Strokes. Seems logical that there'd be a way to do this.

How can I turn Blended Strokes into actual Strokes?

  • I don't get the same result as you when I use Object > Expand on a similar design. It works as expected. See example here I'm not sure what you did. Maybe check your initial strokes are basic strokes without any profile. – Billy Kerr Sep 26 at 9:56
  • @BillyKerr Thank you for sharing this! I am selecting "Expand appearance", "Expand" is greyed out/unusable so not an option for some reason. – MicroMachine Sep 26 at 17:53
  • not on my copy. Expand is available after creating a simple step blend of two strokes. Maybe check you have basic strokes and not some kind of stroke profile applied. – Billy Kerr Sep 26 at 18:02
  • 1
    You can go into the blend in isolation mode and select each of the paths individually and change it to Basic, then you won't have this problem. – Billy Kerr Sep 26 at 19:11
  • 1
    OK, I've added an answer now. – Billy Kerr Sep 27 at 1:57
1

You are getting it almost right, but need to stick to the options under the Blend menu:

  • Make your blend and select it.
  • To turn the blend into separate strokes go to Object → Blend → Expand.
  • This will actually create a group of strokes, which you can then ungroup and edit each piece individually, if needed.

enter image description here

| improve this answer | |
  • 1
    Awesome, thanks. Very weird UI decisions on their behalf, but that's nothing new lol. – MicroMachine Sep 26 at 8:39
  • 1
    Object > Expand works for this too. See example here – Billy Kerr Sep 26 at 9:58
  • See my other comment or the edited question, "Expand is not an option". – MicroMachine Sep 26 at 18:00
1

Further to some exchange in the comments, the real reason for the problem was discovered.

The reason Expand was greyed out for you is because you used the Brush Tool to make the paths, which applied a brush to the path. It wasn't a basic stroke. This means you when you tried to do Expand the Blend, only Expand Appearance was available, and this expanded the brush strokes too which messed everything up.

Ideally, you should have initially created your paths with the Pen Tool or Pencil Tool instead of the Brush Tool. This would have ensured the paths only had a Basic stroke, i.e. no Brush applied. Then when you applied the Blend, Expand wouldn't have been greyed out.

Since you already applied the Blend on brushed paths, to fix it you can enter the Blend in isolation mode, select each path, and change them to Basic in the Control bar along the top. Exit isolation mode, and now Expand will no longer be greyed out.

| improve this answer | |
  • Thank you! A totally valid answer, which might require more time (the part about selecting the path in isolation mode), but works well! – MicroMachine Sep 27 at 5:30
  • @MicroMachine You can just double click the blend to enter it in isolation mode, then select each path and change to Basic, and then double click outside in a blank area to exit isolation mode. It's not really that complicated. – Billy Kerr Sep 28 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.