Can you provide steps to get rid of those ugly borders while painting in Krita. Here's what I am talking about:

enter image description here

Here's how to prevent it in Photoshop but that's not available in Krita.



  • This question was useful. The problem can occur in all situations where colors are mixed, for ex. when retouching a photo.
    – user82991
    Oct 10, 2020 at 6:27
  • Hi. Thanks for the screenshot. However, unfortunately I can't replicate the problem in Krita. Here's my attempt to replicate it, my attempt is above yours. I used the same colours as you, the brush I used is a simple soft edged brush using the Gaussian mask. The image mode is RGB, 8bit.
    – Billy Kerr
    Oct 10, 2020 at 13:11
  • Yep, it's same, luckily those same colors was used. Oct 10, 2020 at 15:49
  • @BillyKerr What's the version of your 8 bit RGB color space? Try the inbuilt sRGB. It has non-linear gamma. You can also have a version of Krita which can calculate color mixes with linear gamma. v4.1.5. mixes colors inside the color space of the image. At least recent GIMP seems to calculate mixes with linear gamma by default (=no this problem in GIMP).
    – user82991
    Oct 10, 2020 at 17:48
  • @user287001 - just the sRGB-elle-Vw-g10.icc (Default). Krita version 4.0.3
    – Billy Kerr
    Oct 10, 2020 at 22:19

1 Answer 1


The problem occurs in color mixing situations:

  • painting with soft or partially transparent brush
  • using blur
  • having a gradient
  • having partially transparent layers.

It can be seen even at anti-aliased color borders because they are partially transparent.

Darker mixing result of bright colors like max. bright cyan and red seems to be caused by the nonlinear gamma property of the common RGB color space.

In Photohop's color settings (=Edit > Color settings) you can force RGB color mixing to happen with linear (=1.0) gamma value but that's not an option in Krita.

An easy workaround is to select linear gamma RGB color space when starting a new image or to convert an already started image with Image > Convert Image color space.

Conversion doesn't unfortunately fix those dark mixes which are in a single layer, but it prevents making them more. Mixes caused by layer transparency and effect masks are fixed by converting to linear gamma.

You get a summary of the selected color space properties if you click the color space browser button:

enter image description here

If the color space is the inbuilt sRGB you have nonlinear gamma (=the white curve). With it you get nearly black looking edges if you paint say bright cyan on bright red with a soft brush:

enter image description here

If you select a linear gamma version of RGB the problem vanishes:

enter image description here

The used color space is this:

enter image description here

The depth is 16 bit integer per channel. Actually one can select depth = 8 bit integer /channel but Krita warns it can cause harms. With linear gamma too high proportion of the available 256 levels is used for dark colors and that can cause banding because well visible bright colors are too sparse.

Conversion from 16 bit depth to the usual 8 bit sRGB with nonlinear gamma is possible when you are ready. It doesn't bring the dark edges back if your image is flattened to a single layer before conversion. But if your image has separate layers where colors are partially transparent the dark mixing results return as soon as you change back to the usual nonlinear gamma, so be careful!

  • Well Thank you, but is there any method to do after painting your art? Or do I have to start the art from scratch? Oct 10, 2020 at 3:58
  • If you have painted in the usual non-linear gamma RGB mode and got dark looking color mixing results into a layer it cannot be fixed. If there's still pure colors in the layers and the mixing happens only as layer blendings you can change the color mode to linear gamma RGB.. Use Image > Convert Image Color Space. Changing image properties is useless. You can convert back after flattening the image.
    – user82991
    Oct 10, 2020 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.