I have small image frames and text frames under which I've added a page sized background image. I can bring the image frames to the front with no problem but the text refuses the show (the frame shows but not the text). Based on earlier post, I've checked for lock symbol and have examined the layers. I've explored moving the text box and background between layers but still can't see the text. I've tried selecting the text to see if there are other options related to that but can't find anything. Any assistance gratefully received

  • Can you select and edit the text? What are the appearance options (opacity, blend mode, etc.) on the text frame and the text itself (note: those are two separate sets of options)? – Janus Bahs Jacquet Oct 20 '20 at 13:52
  • Are you using a master page? Maybe your background is on Layer 2 when the text is on layer 1 on your page. Does this happen when you make a new text frame? Does this happen if you made a new document? What if you hide the background image, do you see the text? Are you using text wrap on the text frame? Hard to say without seeing the document... – AndrewH Oct 20 '20 at 13:56
  • I can select and edit the text if I move it away from the background. I can't see an opacity option for the text and haven't changed the blend mode from default. You've made me wonder if it has to do with the paragraph style options that I'm using,but I can't see anything relevant. – Elaine Oct 20 '20 at 14:17
  • to Andrew H - It's definitely not in the master. Yes, it happens when I make a new text frame also. – Elaine Oct 20 '20 at 14:19
  • 2
    Right, got it. The text wrap setting was the problem. It needs to be "No text wrap" on the background – Elaine Oct 20 '20 at 14:58

Each text box has something called "Ignore Text Wrap" which pretty much does what it says when other objects interfere with the content inside the box.

To turn this on, hit CTRL+B with one or more text boxes selected. The option is also available via Object Styles, in case you need to apply to multiple text boxes quickly.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.