-1

I set up a 10x10 pixels image in PS V21.0.2.

enter image description here

I turned on the pixel grid in View>Show>Pixel Grid and turned off the Grid in View>Show>Grid, and zoomed in to my image.

I however, saw no pixel grid. Protip if you're having the same problem: I eventually figured out I COULD see the pixel grid, but they were set to a white color, not visible on my background.

But whilst trying to fix the above, I tried setting the grid in Preferences>Guides, Grid & Slices>Grid. I changed the Gridline every to 1 pixels with 1 subdivision.

enter image description here

Then I turned on the grid, and what I saw was this:

enter image description here

What you are seeing above is my 10x10 image where I placed a black 1x1 pixel on the diagonal. As you can see, the grid shows 12.5x12.5 squares... My brush size (set to 1 px) shows up bigger than each individual square in the grid.

Here is the same image with pixel grid turned ON, and grid turned off, and a different background color so you can see the pixel grid: enter image description here

As you can see, the grid shows 10x10 squares... as it should be.

Why do the grid settings lie?

  • This question has a duplicate. I'll see if I can find it later. – Wolff Nov 14 at 12:37
  • I found this related question, but I'm not sure it helps you. If your settings really are what you show here it seems like buggy behavior. Could it be related to GPU rendering? Is the grid also wrong if you disable GPU rendering? Does the grid also do this when pixel grid is turned off? What happens if you make for example 10 px grid with 10 subdivisions? – Wolff Nov 14 at 16:18
0

I tried to replicate this but it works fine.

enter image description here

My guess is that you somehow resized the document and now it's not 10x10.

| improve this answer | |
  • Even if the document was resized the grid should still be 1x1 px. Could it be some bug related to GPU rendering and the pixel grid? – Wolff Nov 16 at 17:39
  • This is not an answer. In fact, as explained in the original post -- the diagonal line you see are black pixels made with a 1x1 pencil. As you can see, the image is 10x10 as I could draw 10 of those. So the image was not resized. The grid just does not line up correctly. – KamielDev Nov 18 at 12:11
  • @KamielDev This is an answer to a question that is not a question really. First of all what you are doing? 10 by 10 with a grid line on every pixel? WTF is that? However I did try to replicate it as a potential bug in PS but it didn't happen. Case closed. You might have the wrong/old driver or something. Keep in mind that your question is not just for you, other people will find it and they will see my answer and my answer is useful, because they will understand that this doesn't happen for everyone. – Komental Nov 20 at 17:03
  • @Komental you replicated my steps and showed the feature works on your end. Then you suggested I messed up and resized my document. As you can see in the OP (image of Canvas size), that was clearly not the case. (Besides, what is not to understand when I'm telling you I'm showing you a 10x10 image with black 1x1 pixels going down diagonally from top left to bottom right?? That was actually explicitly there to show you that the document was 10x10 pixels, and not 'accidentally resized') Wolff was the one who made a valid suggestion. Not you. – KamielDev Nov 20 at 19:43
  • @KamielDev You ask "Why do the grid settings lie?" ... well I tried your nonsense and grid settings didn't lie. As far as I understand you would be happier if I didn't try and didn't post but guess what ... I already did. – Komental yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.