0

I am using Adobe Illustrator from Creative Cloud, most up-to-date version.

I have purchased an asset from Adobe Stock and I wanted to save it from .ai to .svg and use it on a web page.

This is how the asset looks on my monitor when I edit it in Adobe Illustator:

enter image description here

Then, when I use the EXPORT or SAVE AS and choose .svg, I open the .svg file in Chrome and Firefox and it looks like this: enter image description here

The shadows are all messed up, it looks like someone turned water over the design and it turned into an oily design. I am not expert in Adobe Illustrator. I just use it to do minor changes to files, so I have no idea what is the problem, maybe I am missing some plugin or something. I tried all possible ways of saving the image as SVG and it always looks like that.

Here is how my export settings look like: enter image description here

Any help would be appreciated! Thanks

  • 1
    You may want to add a bit more decimal places – joojaa Nov 18 '20 at 14:24
2

In Illustrator add anchor points to all elements a couple of times.
In the menu bar go to Object -> Path -> Add Anchors
Then, in the SVG options panel, increase the Decimal Places to the max (7 I think?) and see if the results are any better.

  • Thx, that did the trick! – NVG Nov 18 '20 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.