0

I'm trying to handle an Illustrator compound path:

  • a scanned signature on a white paper
  • vectorised with the image trace panel
  • as you can see in the image, the white shapes in the black mother shape needs to be subtracted from the "mother shape" which is now an compound path
  • when I try to release the compound path I get the error: "can't ungroup the objects".

How can I make the white shapes transparent?

screenshot

what happens after deleting the white shape twice with the white arow: after shape deletion with direct select tool

what happens after using the "select-all" + pathfinder "merge" button: enter image description here

full scene with layers: enter image description here

EDIT/SOLUTION: The merge function from the pathfinder did not solve the problem, it only made the white holes black. Then I just started over completely and did the trace again from the jpg, this time I made sure I selected the: "Ignore White" option checkbox. It worked perfectly. But still no idea how I need to cut out shapes from a compound path.

1
  • 1
    Hi. Welcome to GDSE. In your image trace settings, hit Advanced and choose the option "Ignore white".
    – Billy Kerr
    Dec 4 '20 at 9:58
1
  • Select All (Select > Select All)
  • Click the Merge button on the Pathfinder Panel
  • Click ONE white shape with the Direct Selection Tool (White arrow)
  • Choose Select > Same > Fill & Stroke from the menu
  • Hit the Delete key

When tracing, if you don't tick the Ignore white option, white-filled shapes get created for counters. In 99.99% of these instances you can merely delete the white shapes and under them is actually the compound path (with proper transparent counters).


I took your first image, added a white background and saved it as a jpg...

enter image description here

Opened that in Illustrator CS6 and Image Traced with Ignore White ticked. Then expanded the trace, Direct Selection Tool and dragged to select the outer rectangle, Select > Same > Fill & Stroke, hit Delete..

Result.. perfectly fine compound shape...

enter image description here

12
  • well I've tried that, it works ro get the while-filled shapes get deleted, but still no transparency... when i select the white-fill again and hit delete I get this... (see second image in my edited post...)
    – Kleajmp
    Dec 3 '20 at 23:16
  • @Kleajmp "white filled shapes again" -- meaning you already deleted them once? You should have included that in the question. In that case, Select all and then click the Merge button on the Pathfinder Panel... then follow the steps above in this answer. - Something is "off" in your tracing settings. This should be straightforward. I'd wager you have it set to stack objects (or Adobe's changed the defaults)
    – Scott
    Dec 3 '20 at 23:31
  • wow this "Shape Builder Tool" is totally new to me... seems like I cannot use it (cursor shows a forbidden icon) can we chat for a moment?
    – Kleajmp
    Dec 3 '20 at 23:31
  • You must have the art selected before the Shape Builder tool can be used... in any event, I edited that comment @Kleajmp with an easier method.. :)
    – Scott
    Dec 3 '20 at 23:32
  • so many years I used Illustrator... but I cannot make it work. Can you please write my a step by step instruction? don't understand this tool :-°] I own you!
    – Kleajmp
    Dec 3 '20 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.