2

I am trying to place numbers on successive rows by typing the number and tapping the enter key, then typing a number and so on. I can type the first number, but when I tap the enter key the following numbers do not show up. The overset text box becomes active immediately. If I click on that, it creates a new textbox, but there are no numbers showing up. I can type text, hit the enter key and type more text, and hit the enter key, etc., but numbers don't work.

2
  • Do you have a paragraph rule applied or additional spacing applied in the text editing menu?
    – Rykara
    Jan 8 at 20:45
  • Just to be clear: you can type text with paragraph breaks and it works fine, but if you type numbers with paragraph breaks, it becomes overset? That sounds very bizarre. Does this happen in all documents or just a specific one? Jan 9 at 10:53
1

When editing/setting text in InDesign...

The Enter key means.... Jump to the next text frame.
If there is no "next text frame", the overset text indicator is seen.
Repeatedly hitting Enter will repeatedly "jump to next frame".

Use the Return Key if your desire is merely a new line/linefeed.

The Enter key is the wrong key to use for a "new line".


I'm somewhat assuming that the reason things are fine for you with text is that it is human nature to use the Return key when typing text... and it's equally human nature to use the Enter key when using the numeric keypad.

In many applications, Return and Enter are interchangeable, but an InDesign user should be aware that the Return key is not the same as the Enter key when editing/setting text in InDesign.


This also assumes you have two separate keys for Enter and Return. If your keyboard only has one key labeled for both Return AND Enter, the "jump" behavior is achieved by holding the Command/Ctrl and then hitting the Return/Enter key.

0

Whatever you do, DO NOT hit the Enter on the numeric pad, this has a different effect from the regular Enter key:

  • Regular Enter: creates a new paragraph, otherwise called jumping to a new line.
  • Numpad Enter: this in InDesign is attributed to a Column Break which immediately moves the cursor outside of the current text box and assumes you have another text box threaded. Do not use the numpad Enter if you don't understand this effect.
  • Every time you hit the numpad Enter, you are generating overset text, unless you have a threaded setup already in place.

Also, you can see the entire contents of a text box stripped down of any formatting, by hitting CTRL+Y while editing a text. This opens up the Story Editor and this will show anything you have in there regardless of how many times Enter has been used.

Also, make sure you turn on Hidden Characters using CTRL+ALT+I, which immediately highlights line breaks, column breaks, forced line breaks, tabs, etc.

Read this: https://creativepro.com/a-tale-of-two-enter-keys/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.