0

When a Video Timeline is created in Photoshop, there are 2 options for viewing time units:

  • a Frame Number mode (which is pretty self-explanatory), and
  • the Timecode mode, which I don't understand.

There are 2 kinds of suffixes there : -f and -s, at first, I thought that the -s suffix is meant to mark seconds, but it's not the case. The -s suffixes appear only when I open a video file like .avi in Photoshop but the -s units are much longer than 1 second, the -f ones appear when I create a Timeline within a standard Ps document.

What's the difference between them, and generally what's the concept behind such an unintuitive time units for video in Photoshop?

Edit: A screenshot with -s units:

enter image description here

Eidt2: There are -m suffixes as well (movie duration was about 1h 30 mins, so the suffixes mean probably seconds and minutes, taking into account bigger units in front)

enter image description here

8
  • Cold you please add a screenshot of your timeline panel? I don't see any -s suffixes on mine Feb 5 at 20:53
  • Interesting.. I can find no information on this, nor can I get my version to show an -s in any way. I only see the -f (avi, mp4 both tested). I've tried just about every setting including a smart video layer... always see the -f.
    – Scott
    Feb 5 at 21:08
  • yes, I also can't make my timeline to show -s even if I open videos Feb 5 at 21:10
  • ah! I see -s if I compress timeline and they are seconds. I guess the question is: what do you mean by "these units are longer than 1 second"? Could it be that your video isn't cached so it plays in slower speed? Feb 5 at 21:11
  • @SergeyKritskiy How are you "compressing the timeline" I've tried.. still no -s.
    – Scott
    Feb 5 at 21:16
1

So, not sure what would be 'intuitive time units' but the units PS uses are common (at least between Adobe apps). Each second consists of N-number of frames, say, 25 like on your screenshots. So when your timeline is zoomed in you have

  • Frame 0 is 0:0f
  • frame 20 is 0:20f
  • frame 30 is 1:05f

etc. When timeline is compressed, seconds start to appear, then minutes — hence is -s and -m suffixes. The reason why the seconds didn't feel like seconds could've been because the video wasn't playing in real framerate: notice the value in the bottom of the panel: it shows the actual framerate. Here I'm playing a 4k video in Photoshop, not the best idea:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.