2

I recently exported an AI file as an SVG and there are a ton of "carriage return/line breaks" as nodes in the XML editor. Opening other SVGs does not reproduce this issue.

Is this a UTF issue? AI exporting issue? Is there a programmatic way to remove these?

Not a huge issue, I can simply remove them, but does anyone have any insight on why this is occurring?

If I open a text editor and remove the line break between <g></g> tags, the line break node is gone after reloading. Seems odd considering I have other SVG files with line breaks in them and those are not nodes in the XML editor for Inkscape.

Inkscape 1.0.1

Thanks!

XML Line Break Nodes

1 Answer 1

2

I think this is related to Inkscape Issue #1138: (XML editor dialog) Hide whitespace nodes outside of text elements even when xml:space="preserve" is in root node

There are two ways I was able to fix this for myself. Hope this works for you as well!

Inkscape Method

  1. Open up the XML Editor
  2. Click on the topmost svg:svg element
  3. In the attributes panel, delete the xml:space attribute
  4. Save your project
  5. Either revert your project or close and reopen Inkscape

Text Editor Method

  1. Take a look toward the top of the file (usually the 3rd or 4th line) for the main <svg> tag
  2. Find the attribute xml:space="preserve" and erase
  3. Save the file and open it back up in Inkscape

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.