0

If I am writing something with the text tool, how can I get out of the text tool and select another tool, for instance, the Select tool? I mean only with the keyboard. It would be faster and easier for me to do it only with the keyboard.

I tried the escape key, and it does not work. Any other option?

I have Inkscape 1.0. It seems the last version if I go to Inkscape.org

ADD after reading an answer and making some tests:

In Keyboard shortcuts I have an icon I do not recognize:

enter image description here

I changed the shortcut to Command + Esc and now it works. It seems that the icon I had was meant to be Esc in mac. There should be a bug. It seems that the way to get around is to assign another shortcut

1 Answer 1

1

If you have default keyboard shortcuts in use then

  1. pressing Esc kicks you out of the text tool and deselects all selections
  2. pressing S activates the select tool
  3. pressing TAB selects sequentially one by one the unlocked objects

Keyboard shortcuts are listed in Edit > Preferences > Interface. There you can make customized collections. Beware: there are so many preset shortcuts that special care is needed to avoid clashes.

Keyboard shortcut subclass Edit contains the next:

enter image description here

If you have something else than Escape in row Deselect use it or double click the row and input the wanted shortcut by making it. As well you can reset the default. That can be useless if your version of Inkscape is broken or has a bug.

8
  • Thank you but as I say in my question if I press Esc it does not kick me out of the text tool. If I press Esc and then S, it just writes S. I have a macOS 10.15.7. Have you try it with a Mac?
    – Nrc
    Apr 15, 2021 at 14:51
  • @Nic - it works on Windows. Maybe there's a bug in the Mac version? Have you got the latest version of Inkscape? If it's a bug, maybe report it to the developers.
    – Billy Kerr
    Apr 15, 2021 at 15:36
  • With Mac Preferences are: Inkscape > Preferences > Interface > Keyboard Shortcuts > Edit I have an icon that I do not recognize. I do not have the word Escape like you.
    – Nrc
    Apr 16, 2021 at 7:54
  • Double click that icon and try to type in your own shortcut. No guarantee it works.
    – user287001
    Apr 16, 2021 at 7:56
  • Do you know what is that icon that I have by default. (I have updated the question with an img)
    – Nrc
    Apr 16, 2021 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.