6

In Figma, when you drop an object on a frame, it automatically auto-nests. How do I prevent this?

According to Figma on Twitter I have to hold the space bar. But after trying lots of times this doesn't seem to work. Pressing the space bar before or while dragging an object still puts it in a frame.

I'm on a Mac.

3
+50

Holding spacebar is correct. I'm using the Desktop version of Figma 97.7 on Mac OS 11.3.1

Pressing nothing, will nest the items Pressing nothing, will nest the items

You can see the difference below when holding down spacebar. Watch the layer panel to see the difference between holding spacebar and not holding spacebar when dragging items into frames.

Holding spacebar will prevent nesting Holding spacebar will prevent nesting

1
  • Strange, it now seems to work.. maybe I had a bugged version or something May 18 '21 at 9:11
2

To prevent auto-nesting, hold the spacebar before you drag over the frame.

enter image description here

On a Mac, Safari 14.1

1
  • Came here to learn exact the same trick :) The only thing I'd add is that it's important to first click and hold an element before pressing the Spacebar, and then you can drag it to another place without nesting. Otherwise it didn't work for me.
    – Nekto
    Aug 28 '21 at 0:02
-2

No other visual editing or design tool treats layers like this. It's not a common convention, it's additive and it should work as such. You shouldn't have told down spacebar for Figma to behave according to convention, instead you should hold down spacebar to enable this new behavior.

1
  • Right, but this is more of a rant than an answer to the question. Check How to Answer to learn a bit more about what the site is about.
    – Luciano
    Jul 20 '21 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.