0

I've never had this issue before, so I'm super confused, it was working fine up until last night. I create a PNG by removing the background of my image, and I'll usually export it as a PNG with transparency ticked and open in Illustrator or just drag straight from Photoshop into Illustrator and go as usual, but now I'm getting this. It's got a white background which is super confusing.

This is how it looks in Photoshop after I've removed the background:

enter image description here

And this is what I get when I drag, copy & paste or place into illustrator:

enter image description here

It still has the white background and it's very frustrating ):

Please help if you can, thank you!

2
  • 2
    How did you export the photo, this particular photo from Photoshop?
    – Vikas
    Commented May 15, 2021 at 16:39
  • 1
    Illustrator on Windows has some problems with copy pasting transparent PNGs. I don't know why, since Windows supports transparency when copying and pasting generally, but for whatever reason, Illustrator doesn't support it. Instead, save your work as a PSD, then place it in Illustrator.
    – Billy Kerr
    Commented Oct 12, 2023 at 13:05

3 Answers 3

1

I tried but can't find how it can happen.

Notes:

  1. If you have a layer with transparent pixels in Photoshop, and you make a selection of whole layer (for example your photo with no background) and paste it in Illustrator, it will be pasted with white background.

  2. Same will happen if you make the selection and drag it into Illustrator.

  3. Last option is placing the photo. If your PNG image is exported properly, it should retain transparency.

Since there is a bit lack of information in question, I'd suggest check to steps again, how you saved the file and how you're placing it. Maybe placing wrong file... Maybe something else. I feel it's very less likely a bug.

0

I was able to make the white background become transparent by rasterizing the image in Adobe Illustrator.

Select the layer > click Object > then click Rasterize... > check the settings and click OK.

enter image description here

0

A work around is to use image trace on the png. When you do this the background reverts back to white. Click the Expand button on the options bar and this will break the tracing into pieces- similar to creating outlines with type. Then click on the white background with the magic wand. Lastly, hit the delete button on your keyboard to remove the white background

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.