4

How can I prevent InDesign from overriding my prime signs (ie, "minutes" Unicode 0027) with apostrophes (Unicode 0313); and likewise the doubled forms?

Primes are required for describing latitude and longitude, for instance, S28°23ʹ; E151°42ʹ.

However often I put them in, after I have saved they have turned into apostrophes when I reopen the document.

Is there a way to set up a character style or any other way to prevent this override?

0

2 Answers 2

9

If the codes you write in the question are accurate, then that’s your problem right there: the Unicode character U+0027 is not a prime. It’s a simple, typewriter apostrophe, and the setting mentioned in Wolff’s answer is likely responsible for them being changed into curly apostrophes.

The correct code for a prime is U+2032; this character is never interpreted as an apostrophe or quote mark and never changes, regardless of what you have your Use Typographer’s Quotes setting set to.

Note that U+0313, which you mention as being an apostrophe, is also a different character: it’s the Combining Comma Above, which is used, among other things, to indicate smooth breathing in Ancient Greek. Crucially, U+0313 is a combining diacritic, meaning that, unlike apostrophes and letters, it doesn’t take up any space on its own, but is instead placed above another character without (usually) affecting the width of the base letter.

1
  • 1
    Nice catch! I didn't pay attention to the Unicode characters (and would have to look them up anyway).
    – Wolff
    Commented Jun 2, 2021 at 22:07
4

Your problem must come from having Edit > Preferences > Type > Type Options > Use Typographer's Quotes turned on.

However, I can't reproduce the issue with a change happening when saving. The quotes should only change when entering them. Just turning on Use Typographer's Quotes doesn't change existing characters. That would cause text to jump around in your document just from changing one setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.