2

I am starting with affinity designer and I want to join different objects to create one shape. The objects I am working are these:

Example of objects

I thought that selecting all the objects and using the geometry function add would result in the intended shape, but the outcome is this:

Outcome of the add function

As you can see the shape is a bit weird. There are unnecesary nodes that should be deleted and the parts of the shape are completely disconnected. I understand that the problem is caused by the fact that the objects are collinear but not overlaping. The shape, once exported looks fine, but if I try to add a border it will look weird:

Example with border

Is there an option to solve this problem? Am I doing something wrong? Is there a way to merge the different parts of the shape with collinear borders?

In this last image I have created a gap between the different parts to show more clearly how the nodes have been generated:

enter image description here

Thanks!

2
  • Did you have snapping turned on when you created the individual pieces of the shape?
    – pbasdf
    Jun 27 at 16:05
  • What happens if before trying the Add boolean operation, you remove the stroke? Do the shapes actually abut each other, or is there a gap.
    – Billy Kerr
    Jun 27 at 18:20
2

If you draw your pieces so that you make them to fit exactly against each other by having snap to grid ON the parts will NOT make a gapless union when you try to combine them with Boolean Add.

That's caused by an unfortunate default setting in the preferences. There's performance option "Use precise clipping" which is OFF by default. I tested it with the next example:

enter image description here

When the pieces in the left were drawn by having snap to grid ON and Use precise clipping in the preferences ON the union was made perfectly.

I drew the same pieces without precise clipping. Boolean Add left gaps in the seams like in your example. The gaps appeared also if precise clipping was OFF when the Boolean add was applied. For exact results precise clipping must be on both when drawing based on the grid and when applying Boolean operations.

It worked without precise clipping, but only if the rectangles were converted to curves and their corners were moved forth and back with the node tool until they gave the yellow snapping indication:

enter image description here

Snap to grid must be turned OFF and snap to geometry and key points must be ON. And every corner must be made to fit separately. Or actually not all. Rectangles can be stretched to overlap each other. The union will still be right.

I assumed a while that the problem you presented is cosmetic if you do not have a stroke. But it is not. There's 1...2 px wide transparent anti-aliasing zone

Very frustrating, I'd say! So, keep precise clipping ON.

ADD: Later tests have shown that "Use precise clipping" often does not fix it if the perfectly fitting seam is curved. A workaround is to insert overlaps either as new drawn items or by editing the seam.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.