0

The lines of the circle and line interact perfectly but when I expand and divide it looks like the stroke setting throws it off and the shapes don't meet perfectly?

I am zoomed in a lot so not sure if this is the best I can get it?

ZOOMED OUT

ZOOMED IN

INTERSECT AND STROKE SETTINGS

1
  • Either they dont meet perfectly, its an artifact of the GPU rendering, or simply because illustrator can not make true circles.
    – joojaa
    Jun 29, 2021 at 22:39

3 Answers 3

1

You should draw the lines so that they really snap in the same points:

enter image description here

The red line is drawn by having smart guides ON. They indicated "crossing" at the line ends. Often the scene is tighter and smart guides give too many indications. Then I have inserted new anchor points to the crossings and kept Snap to points ON.

If the line must be longer it can be stretched by holding the Shift key at the same time. That keeps the direction. Also the midpoint stays if you hold Alt+Shift when you stretch the line.

enter image description here

Expand sounds bad. The lines become filled areas. Just that can be your problem.

When the line is stretched one can fill the areas with the Shape Builder:

enter image description here

The borders of the areas are exactly in the middle of the curves.

The fill color is changed between the fills.

Learn the Shape Builder tool from the User's Guide. It's one of those Illustrator's extraordinaries that the makers of low cost graphics programs haven't succeeded to rival, no matter they have had more than a decade time to do it.

Deleting the remnants, removing the strokes and zooming in to the maximum do not reveal any errors

enter image description here

ADD: Checked questioner's version. 6400% (no more available here) zoom in doesn't show any error in my legacy Windows system.

But the corner node in the 3rd version where 3 colored shapes meet looked somehow thick. I selected the nodes with the direct selection tool and aligned them horizontally and vertically. The node became as thin as a single node.

I repeated questioner's drawing steps (=used Pathfinder Division instead of the Shape Builder). Scaling the image to 1000% and watching with 6400% zoom in revealed some error:

enter image description here

Pathfinder (see its options menu) has precision setting. But reducing the allowed error didn't make it better. So, the problem stays unexplained. Maybe the limit of the used math has been met.

Try as a workaround to select the nodes of the corner with the direct selection tool and align horizontally and vertivally.

Shape builder made it still OK, no visible error after scaling.

2
  • Thanks @user287001, I did this and it's still doing the same thing for me. I've uploaded the Illustrator file [here] (drive.google.com/file/d/1FoZAv3dXMdRzuchi7cVqLg_w52XwrcxP/…). I'm getting this random shape whether CPU or GPU is selected and I'm working on a new Mac. It only shows when zoomed right in so probably isn't visible to the naked eye. If needed I'll just delete the random shape, it just seems strange that I can't get it perfect when everything is lined up on the original line drawing?
    – Topher
    Jun 30, 2021 at 5:48
  • @Topher is gap detection on? Cutting a bezier is a tradeof between minimizing of tears vs minimizing of errors. The sytem is minimizing tears at the moment try using cut tool instead this allows you to prioritize the item to cut.
    – joojaa
    Jun 30, 2021 at 13:13
0

This is more of a guess than anything....

After the divide operation, with everything still stroked, if you are seeing something such as this...

enter image description here

It's due to the angle created at the anchor points. There are two possible solutions here...

  1. Change the corners to rounded or...
  2. Lower the Miter (The Limit field on the Stroke Panel) to a value that doesn't create a sharp point

enter image description here


The larger mystery to me is... if you remove the strokes and then apply fills, this should never be an issue. That little piece is only there because of the strokes.

You seem to be getting that "spare" shape because you are doing something between the divide and subsequent filled shapes. What that is, I don't know. I can only guess that you may be possibly expanding the strokes at some point? Or using something like Live Paint rather than merely adding fills?

2
  • Hi @Scott, thanks for the reply. I created a fresh version with no strokes and only clicked divide pathfinder but the same thing happened. I'll keep trying, must be doable!
    – Topher
    Jun 30, 2021 at 12:38
  • It could be a bug @Topher I'm not using the "bleeding edge" version of AI.
    – Scott
    Jun 30, 2021 at 12:42
0

Adobe Support said that this is expected behaviour when using the path finder. The software tries to adjust each and every shape and can cause this shape to prevail.

Only way around it is to use the Shape Builder Tool as mentioned above.

1
  • Yeah the tool tries to minimize tears so it finds a solution where all endpoints are possible. Thats why you sometimes have to fall back to cut tool.
    – joojaa
    Jul 5, 2021 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.