3

enter image description hereenter image description hereenter image description hereim new to Inkscape and need it urgently for some figures. So, I have two images i copied and pasted into inkscape. Everything looks good until I try to export it as png and suddenly the lines of both images appear. How can I remove those lines in inkscape since they are images and not vectors?

Thank you!

7
  • Hi. Welcome to GDSE. What do you mean by "the lines of both images appear"? Can you share an image showing the problem, or perhaps share the SVG? Are you trying to edit a raster image in Inkscape? If so, then that won't work. Inkscape is a vector image editor. It can't be used to edit raster images. Also "nodes" in Inkscape are not green lines, so I don't know what you mean by that either. What kind of image did you paste into Inkscape? Was it a raster image or was it vector? Can you please edit your question. Thanks.
    – Billy Kerr
    Jul 10 at 13:40
  • Hi, thank you for answering. I am trying to upload the png and the svg however it says that its too big. Therefore I am sharing screenshots of it. As you can see in the png file there are some light lines appearing sorrounding the boxplots, whereas in the inkscape they dont. I think I am not using the correct terminology but when I am using the display option of outline the exact lines that appear in png are appearing in green but I cant delete or cover them (third pic)
    – Ana
    Jul 10 at 14:39
  • upload the SVG to svgshare.com
    – Billy Kerr
    Jul 10 at 15:13
  • Can you also tell me what software was used to create the SVG, because if it wasn't created in Inkscape, that could be the problem.
    – Billy Kerr
    Jul 10 at 15:27
  • svgshare.com/i/Yz5.svg
    – Ana
    Jul 10 at 15:31
2

After checking the SVG, the construction is a bit of a mess TBH. It contains both raster and vector elements with the raster images contained within clipping paths. These seem to be creating conflation artefacts around the clipped raster images, i.e. where the solid areas meet the transparency. It's a bit weird though to be honest. I wouldn't have expected that. Might be Windows Photo viewer to blame. It's not good with transparency.

One possible fix is to create a white filled rectangle the same size as the page.

  1. Enable the page borders in the Document settings.

  2. Use snapping to page border to get it the rectangle to fit exactly.

  3. With the white rectangle selected press End or do Object > Lower to Bottom. Basically this will create a white background behind everything.

  4. Finally in the Export dialog use the "Page" option for exporting.

Here's an example PNG output using that technique, looks good.

enter image description here

4
  • Omg that worked!!! thank you so much! I am so new to all of this and have been trying since yesterday to find a solution. I appreciate your help, THANK YOU!
    – Ana
    Jul 10 at 16:35
  • @Ana I just had a look at something else, possibly the problem is with Windows photo viewer. It doesn't work properly with transparency.
    – Billy Kerr
    Jul 10 at 16:36
  • Even better! Thanks alot Billy!
    – Ana
    Jul 10 at 16:54
  • It seems that @BillyKerr has an answer that worked for you- if that is the case please mark his answer as correct and give him an upvote. This helps others on the site find solutions to their similar questions.
    – Kyle
    Jul 10 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.