21

I am trying to bucket fill a layer, but I get this crazy cursor I cant get rid of. I think its because I have something selected. I tired Select All, Select None, but the cursor does not change.

I cant get a hold of that image, screen dump does not get that cursor. Its a small circle with a line across the diameter 45 degrees.

Edit : That cursor is called "circle-slash" icon. It comes when I select a part of the image and try to fill a different part of the image. I either need to select things correctly or I need to edit my selection for painting.

Edit Again : cursor with circle-slash

9
  • 1
    Is the layer you're trying to fill locked?
    – Brendan
    Jan 14, 2013 at 21:59
  • 2
    A screenshot of what you are seeing might be helpful
    – Yisela
    Jan 14, 2013 at 22:21
  • I cant give a screen shot, since the cursor does not show up on the screen shot. For some reason it shows up as a regular arrow cursor. Something to do with the way screen shot is taken on ubuntu I guess.
    – Siddharth
    Jan 15, 2013 at 3:10
  • 1
    Wow, that was exactly my scenario. Thank you!
    – vincent
    Sep 6, 2021 at 19:44
  • 1
    God, the usability on GIMP is absolutely dreadful. I need to stop being so tight and pay up for Photoshop!
    – garryp
    May 21, 2022 at 12:45

9 Answers 9

20

Here's the answer you're most likely looking for:

Scenario: say in GIMP you have a logo image, you increase the Canvas, center the logo inside the enlarged canvas, and you want to fill the extra canvas with an eye-dropper color. However, the paint bucket shows a black circle with line through it indicating no-can-do.

Do this: from menu, select "Layer", then "New from visible". Now you can paint bucket fill.

2
  • 2
    This worked, but how does it work? I'm hating GIMP.
    – NiteCyper
    Dec 12, 2016 at 4:18
  • Well, now "it works" but it simply results in a "no-change" non-event event. That is, it fails silently. Failing silently is a supported feature in GIMP? Hmm, not a design spec I'd approve. Anyhow, a no-fill-event occurs when the fill-event is activated. I've played with various colors and patterns, but the bucket fill does not fill the rectangle drawn with the rectangle select tool. Sep 30, 2019 at 13:26
3

Michael Schumacher was right about the root cause. The layer has a fixed size. So the correct answer, at least for Gimp 2.8 is to select the layer, then select "Layer"->"Layer To Image size" from the menu.

3

The circle-slash is a indicator that I cannot do that operation as yet in the part where the cursor is currently. I need to move the cursor to a part of the image where it is allowed.

Sometimes the select none option is not visible. GIMP would not allow Select None, that felt wierd. But in such cases, select all, select none works, but sometimes does not. That said, the root cause of that circle-slash is known now.

4
  • If you're on Windows you can install Greenshot which allows screencapture with the cursor.
    – icc97
    Jan 15, 2013 at 15:06
  • Thanks, I have managed to create that cursor. Hopefully the question is more clear. I do want to make sure that my question is not downvoted. It is a valid question, I just need to ensure that its clear and useful to the community.
    – Siddharth
    Jan 16, 2013 at 3:25
  • 1
    Just to round things off well, why not take your answer (which you basically edited into your question), edit it into this not-quite-an-answer, then accept it. That way the question shows as answered, which it is. Jan 19, 2013 at 3:30
  • Very simple and worked for me. I'm assuming that sometimes Gimp gets confused about where the selection is. This is an easy brute-force way of re-establishing the selection. Thanks!
    – SMBiggs
    Aug 30, 2017 at 5:51
1

I had this same problem, and it was driving me insane. Make sure you have "Background" selected as the layer you are working on. Once I selected it, I could fill in my rectangle select.

1
  • 1
    The important part is to have a part of the active layer at the location of the selection that is to be filled. The Background layer fulfills this in many, but not all cases - you might have changed the canvas size, or you might have moved the background layer. One thing that is weird to some users, but comes as natural to long-term GIMP users: layers have a finite size in GIMP. This is a long-standing enhancement request, but as it is a bigger change and there's always other stuff that has to be worked on, it has not been tackled yet: bugzilla.gnome.org/show_bug.cgi?id=93639 Jan 7, 2015 at 9:32
1

I don't think this is the issue OP experienced but the issue I had seems related. GIMP can save a selection area to file. If the file was saved after selecting a single pixel on a large image, the next time it's opened every paint bucket, pencil, brush, etc operation won't work on any layer (except for that single pixel which you might not notice). Just select or deselect all.

1
  • thanks, this is the correct answer, the dashed line around confused me, I forgot that the dashes must be moving to mean selected. May 21, 2020 at 10:03
1

Another potential solution if creating a new layer from visible does not solve the problem. I had an image where I cleared out the solid background using "Color to Alpha". I could not get GIMP to bucket fill the inside area of the image. I then checked on "Fill transparent areas" checkbox in the Bucket Fill Tool Options (below "Finding Similar Colors" heading) and that did the trick.

0

I see this is an old question, but I'm going to add another answer anyway since it might be a fix that some people might find helpful.

The real problem here might be that the layer boundary is smaller than the canvas. This is a bit of a guess though.

If this is the case, then it's easily rectified by using Layer > Layer to Image size. This kind of confusion often occurs if a user disables the View > Show layer boundary option, and therefore has no idea or indication where the layer boundary is. If you switched this off, I suggest you switch it back on. The layer boundary shows as a yellow dashed line.

The reason the Bucket Fill Tool fails to work outside the layer boundary is because in GIMP (unlike Photoshop), layers can be a smaller than the canvas. Quite literally, there are no pixels to edit outside the layer boundary. The fix I suggested rectifies that issue.

0

I found this thread and @Siddharth post helped me, but I can't comment. But how I fixed it was I did ctrl+a and then I could magically use the paint bucket again. Such a silly bit of functionality.

1
0

I had a similar problem. Bucket fill did nothing but other tools worked. Then I spotted Opacity was set to 1 in the bucket fill tool options. Set to 100% and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.