0

Transparency does not seem to be working with cut/paste within GIMP. I have used GIMP on Windows before without this issue, but I'm wondering if this is an issue with with GIMP on Linux (on a Chromebook). I'm trying to cut images and paste them with transparent backgrounds, but it isn't working. Here's a very simple example to show what is happening:

  1. Setup: Just to make sure I wasn't doing something silly to start after experiencing this issue. I upgraded to the latest version, GIMP 2.10.24 and I did a reset on my preferences (other than unchecking "use tool groups")
  2. Set forecolor to red and background to white.
  3. Create new canvas. It creates a blank background in white as expected.
  4. Create new transparent layer. (gimp1.png) New layer
  5. Hide Background and click on new transparent layer. Confirm this layer is selected and that Alpha is visible.
  6. Create oval with Ellipse Select and fill with red. (gimp2.png) Create oval
  7. Use Fuzzy Select tool to select red oval. Ctrl-X. Ctrl-V. Floating Selection created as expected. However, I see a black background instead of transparent as expected. (gimp3.png) Fuzzy Select and cut
  8. Right-click on floating selection and choose "To New Layer". Still black background filling in square around oval rather than transparent as expected. (gimp4.png) New layer
  9. File/export as : make sure file is png. (gimp5.png) Export As
  10. I would expect the output to be just the red circle with transparent background, but instead, the black around the red still appears in the png file. (gimpoutput.png) Output

Fuzzy Select Options FuzzySelect

Thoughts on what is happening?

3
  • Can't reproduce on my 2.10.24. What is the image mode and precision? Can you show the fuzzy select options and the Layers list? After the fuzzy select, what do the marching ants look like, are they around the ellipse or around its bounding box? Is it only with the fuzzy select (if you select/copy/paste an irregular shape obtained with the free hand, is it the same behavior)?
    – xenoid
    Jul 23 at 19:29
  • Mode: RGB. Precision: 8-bit integer/Perceptual Gama(sRGB). Fuzzy select options. I'll include above. Layers list: included in some of the images above in the bottom right corner. After fuzzy select, marching ants are around the circle (not the square). It is not only fuzzy select; I get the same behavior with Select By Color Tool and irregular shape with Free Select Tool. When I do the Free Select Tool, it seems to cut properly, but then paste with the square around the selected area.
    – YKStacker
    Jul 24 at 20:23
  • 1
    I tried following all your steps, and I can't replicate this issue either on 2.10.24.
    – Billy Kerr
    Jul 24 at 21:27
0

This is issue https://gitlab.gnome.org/GNOME/gimp/-/issues/4551 - unfortunately no reason beyond "this has to be something strange that's specific to Chromebook/ChromeOS" has been identified, and no solution is known yet.

0

Possibly a bug, see this.

Since the bug is reported for 2.10.24, downgrading to 2.10.22 or 2.10.20 could be a workaround.

Otherwise, is there anything interfering with your clipboard such as a clipboard manager? I had problem with image due to Klipper (the clipboard manager in KDE) and disabling it for images solved my problem.

7
  • Hmm ... that bug report is for revision 1. I think revision 3 is the current stable. I can't reproduce in that version. But yeah, disabling any software which might conflict is probably a good idea.
    – Billy Kerr
    Jul 24 at 21:38
  • 1
    @BillyKerr AFAIK there are no "revisions" in Gimp versions, they only happen for Windows installation (so the Gimp version is the same), and the OP is on Linux on a Chromebook.
    – xenoid
    Jul 24 at 21:45
  • Must be OS specific then. I'm on Win 10, yes I updated to revision 3.
    – Billy Kerr
    Jul 24 at 21:47
  • @xenoid the only other Linux install I have is Audacity. I'd say I have a pretty vanilla Chromebook. I mostly use Chrome and have only a few other apps installed. What else can I check to see if there might be a conflict or interference? Also, I originally had this issue with 2.10.8 and i just upgraded to 2.10.24 hoping that would fix the issue (obviously without luck).
    – YKStacker
    Jul 26 at 2:34
  • That could be a problem with the standard clipboard manager (in my case, I didn't install Klipper explicitly).
    – xenoid
    Jul 26 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.