0

I have been trying to answer a question here: Is there a way to Batch package AI files.

So I wrote an answer (which I have currently deleted for the time being), advising the OP to record an Action, and use Insert Menu Item, to find the Package command. Then run the Action on a Batch of AI files in a folder, and output the packaged files to a destination folder. However after writing the answer, I thought I had better test it . . . and guess what . . . it didn't work!

enter image description here

In theory I think this should work, but for some unknown reason, it didn't actually package the AI files at all. It merely saved a copy of the AI files in the destination folder, without any of the linked images/fonts, etc.

So, I then tested running the File > Package command on a single file without doing it via an Action, and the packaging feature seems to work just fine.

I also tested the Action I recorded on an open document, without applying it using Batch, and it also works fine. So the problem doesn't seem to be with the Action itself.

I'm wondering if this might be a bug (I tried googling, but no joy), or perhaps there's something I forgot to do. Or perhaps the Package command just won't work in an Action in Batch. Does anybody have any clues as to why this isn't working, or a similar experience? Just a note that when running the action as a Batch, no error messages appeared. I'm also running a rather old copy of AI CC 22.1 (2018), on Win 10 if that's relevant.

BTW I realise this is on the verge of being a tech support question, but thought I would reach out to the community. It's absolutely fine if this gets closed, but a few comments might be helpful.

0

I think I have now worked out what is going on here.

When running the Batch, I failed to notice that when the Package dialog opened for the first time, the location of the package was not set to my desination folder, but a default Package folder located in my Documents folder.

So not only do you have to set the destination folder in Batch but also in the Package dialog.

Such a silly mistake. Anyway, all seems to be working now. Thought I'd share it just in case anybody has a similar brain-fart moment.

Edit: I've updated and now undeleted my answer to the OP's original question, if anyone is interested.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.