0

I'm doing some calendars and I need the numbers to be aligned to the center of the square but I can't align properly because of the blank space that is above the number.

I've trying to use the Area Type Options to reduce the bounding box size in these numbers, but I can only resize the bottom part of the box, not the upper one, how can I resize so it fits completely without converting to outlines?

tia.

enter image description here

1 Answer 1

2

You can't.

The bounding box uses the defined glyph box of the font as a minimum size. If the glyph box, as designated in the internal font information, contains extra space, the bounding box can't be made to ignore that.

You can use some trickery though, without converting to outlines.

In the Preferences > General, tick the "Use Preview Bounds". Then select the text object and choose Effect > Path > Outline Object. This effect won't cause any noticeable visible difference in the type but will cause the area type box/bounding box to use the visible area as a basis for its size.

enter image description here

Once things are aligned, you can untick the Preview Bounds preference again if it gets in the way (it can at times). You'll see the extra space again, but it shouldn't matter after you've already aligned things - the position of the object won't change if you turn off the Preview Bounds pref after aligning. (You could also remove the Effect after aligning if desired.)

Of course, you could also use Point Type rather than Area Type in many instances.

Possibly related: Align text in exact center (vertically and horizontally) without creating outlines?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.