0

My goal is to hide the "child shape" part which is outside the "parent shape". See below the image, the green shape outside the black shape should not be seen.

The problem is that after I clicked the "create clipping mask" instead of hiding the child shape that is outside the parent shape, the parent shape vanished. This is what it looks like after "create clipping mask"

enter image description here

Reference:

  1. Illustrator using Clipping Mask.

enter image description here

2 Answers 2

0

One object should not act as both a visible object and a clipping mask.

Clipping masks should be separate objects.

  • Undo your mask
  • Copy the parent shape - Edit > Copy
  • Paste in Front - Edit > Paste in Front
  • Hold Shift and select the shape you want to mask
  • Now create the clipping mask.
0

Looks like you are merely clipping a visible line to the shape below - that's not going to work for what you are trying to do.

If I've read your question correctly, sounds like you want create an actual vector mask. Basically, you'd use the Pen Tool to make a Path (in the tool options set "path" instead of "shape"), then do Layer > Vector Mask > Current Path.

Example showing a shape layer which must be converted to a Smart Object first, then a vector path applied as a mask.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.