2

I am trying to export the canvas of an illustrator file only to svg but when I try to open the file, the drop shadow of the objects in my file are still visible outside the canvas. I am relatively new to Illustrator.enter image description here

See the shadows present at the top and bottom of the image.

3 Answers 3

0

You could use a clipping mask.

Basically, you prepare a rectangle of the area you really need and put the shadow inside.

Here is the explanation from adobe's website: https://helpx.adobe.com/mx/illustrator/how-to/illustrator-creating-basic-clipping-mask.html

1
  • Thank you, that solved it. I tried doing it with the pathfinder tool earlier on and it didn't work. Aren't the two methods equivalent ?
    – user171823
    Commented Feb 2, 2022 at 2:20
0

Group all your shapes together that you want inside the 'canvas' (ctrl/cmnd-G) Create a shape that acts as the border of your canvas and place it on top of your grouped shapes. Make a clipping mask, selecting both of the above (right click -> make clipping mask). add your desired drop shadow to that clipping mask.

0

When you export as SVG use File > Export As, select SVG as the format, and select the "Use Artboards" option.

enter image description here

Here's an example result. The artboard will crop the drop shadow.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.