2

I'm working on a 72ppi PSD file.

A have hundreds of files in different ppi (96ppi, for example) all of them are 800px tall

When placing them in the PSD, intead of being 800px tall, they are smaller. I KNOW this is a totally normal behavior WHEN PRINTING.

But since I'm not printing them, is there a way to make Photoshop respect the pixel dimensions instead of the ppi value?

Checkin "Don't resize images when placing" does not work. This just changes the % size of the smart object to fit PSD.

I can batch edit the ppi EXIF info with some linux commands, but I'd like to know if there's a way to do it automatically when placing.


TL;DR EXAMPLE:

300 ppi PSD 1920x1080 pixels. Place a 72ppi 1920x1080 pixels photo.

Placed smart object will not be 1920x1080 since PS changes the dimension due to different ppi.

Any way to avoid this?


Please, don't explain me what ppi is because I understand that. And don't say that ppi does not matter when working on computers and only matters in printing. I know this does not matters but it seems to matter to Adobe since they change the placed images size.


Thanks!!!

1
  • What you are essentially asking Photoshop to do.. is degrade any lower resolution image when it's moved to a higher resolution file - just automatically make a 72ppi image a 300ppi image and maintain pixel dimensions. Photoshop tries to never be destructive in such an automatic manner. PS essentially forces the user to be destructive intentionally so they can see the damage they are doing. The actual solution is to have all files the same PPI as opposed to trying to mix different PPI values in the same document. Change the PPI of the 72PPI image to 300PPI before moving it.
    – Scott
    Aug 21, 2022 at 21:14

1 Answer 1

1

Try this, in Preferences > General, uncheck the two options shown below

enter image description here

4
  • Hello. Thanks, but I already tried that. I've stated it on my question but did not remember the exact name of the checkbox. First one just reduces the size (only in % while maintaing the wrong pixels) if it does not fit and the latter just omits the "Control+T" transform after placing. Thanks anyway!
    – Hache_raw
    Feb 22, 2022 at 17:46
  • @Hache_raw - so next I would try deselecting the "Always create Smart Objects when Placing" option
    – Billy Kerr
    Feb 22, 2022 at 17:57
  • Thanks again, I've already tried that also. It just place the image directly rasterized :( As I was on a hurry I just changed all ppi in batch with a system command
    – Hache_raw
    Feb 22, 2022 at 18:16
  • @Hache+raw - yes it will place the image rasterized, but it should be the correct size. You can then convert to a smart object if necessary.
    – Billy Kerr
    Feb 24, 2022 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.