0

Recently I did something in GIMP, and now no matter what image I open, (almost) none of the tools work.

I can't draw, I can't erase, I can't make a rectangle or fuzzy selection ... the Move tool is the only one that works, and even it only works if I enlarge the canvas to make room (I'm pretty sure I could move parts of the image "off screen"). Many (but not all of the tools) even have a little circle with a line through it when I try to use them.

I don't have any selection on these images, I am in RGB mode, I've tried adding layers, and I've tried a bunch of other fixes online that (similarly) didn't work. I even tried uninstalling and reinstalling Gimp.

Does anyone have any idea what I could have done to put GIMP into this useless mode?

EDIT: Here's a screenshot of my GIMP.

enter image description here

7
  • Please add a screenshot of your Gimp UI showing the Layers list and the titlebar. Otherwise, here and here.
    – xenoid
    Commented Mar 16, 2022 at 20:58
  • Screenshot added. I checked everything on both of those lists, but none helped :( Commented Mar 16, 2022 at 21:51
  • Not visible but I assume you did "Select >None" (or it is grayed out). So given the screen shot above, if you click+drag the mouse across the picture, nothing happens when one would expect some erasure (or replacement with white)?
    – xenoid
    Commented Mar 16, 2022 at 22:03
  • Correct (both about selecting None ... I even selected All and then None to be sure) and about nothing happening when I try and erase ... or make a rectangle selection, or move the image, or use any other tool. Commented Mar 16, 2022 at 22:07
  • If the paint tools (bucket/blend/brush/eraser/airbrush/pencil) don't work but the transform tools (scale/rotate/flip...) do, a possibility is that all channels are deselected in the Channels list. Otherwise no better idea than renaming your profile to start fresh.
    – xenoid
    Commented Mar 16, 2022 at 22:34

1 Answer 1

2

If the paint tools (bucket/blend/brush/eraser/airbrush/pencil) don't work but the transform tools (scale/rotate/flip...) do, a possibility is that all channels are deselected in the Channels list (because paint operations only apply to the channels that are selected).

When nothing seems to work, it can be a problem with your Gimp profile. Reinstalling Gimp is rarely a solution because that will keep the profile and its data. So the good solution is to rename your profile, and start Gimp again. It will create a new profile from scratch which should normally be OK. You can then copy things (typically, assets: brushes, patterns...) from the previous profile if necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.