0

When I press the Delete key or use the Edit -> Clear option, GIMP instead 2.10 instead fills my selection with my background color. How can I actually delete (set alpha to zero) the selected pixels?

2 Answers 2

4

This is because your layer lacks an "alpha-channel" which is where the pixels opacity is kept. Without this pixels cannot be transparent. A clue for this missing alpha-channel is that the layer name is in boldface in the layers list.

You can use Layer > Transparency > Add alpha-channel to add an alpha-channel when needed.

Gimp does this because when you load an image in a format that doesn't support transparency (JPEG...), this shows you how the image will be saved. Otherwise you would be wondering why the transparency you had in Gimp was replaced by the background color in the exported file.

In Gimp 2.10 there is an option to always add an alpha-channel to imported images:

enter image description here

1

Right click the layer in the Layers view and click "Add alpha channel". Without an alpha channel, you can't have transparent pixels and so can't delete them. Helpfully, GIMP's default behavior when you attempt to delete pixels without an alpha channel is to just fill them with your background color and not tell you what's going on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.