I'm having this problem with illustrator where, even though I have already changed all units to millimeters (general, stroke and type), the measurements of artboards and canvases are still being measure in points, both in the suggested presets like in the image here

enter image description here

as well as when making a custom one. What do I have to do to change this to millimeters?


1 Answer 1


The Presets will always show that way. As you see some show their measurements in Points and some in Pixels.

Simply go to File> New or choose the Create New button from the home screen and you can set your Artboard size in the units of your choice.

enter image description here

  • What version of Illustrator is this? I'm still on CC 2018 and all print presets are shown in mm, and not points. see screenshot. I wonder if this is region specific thing.
    – Billy Kerr
    Commented May 1, 2022 at 9:18
  • What's your region @BillyKerr
    – AnFa
    Commented May 1, 2022 at 13:27
  • @AnFa - I'm in the UK, my Windows PC is set up for UK, and my Illustrator installation was set to "International English"
    – Billy Kerr
    Commented May 1, 2022 at 13:43
  • @BillyKerr I changed my language to International English and it still is using point units in that screen. This is CC 2022
    – AnFa
    Commented May 1, 2022 at 16:29
  • @ Billy Kerr- I opened 2018 (I use 2021 these days) and it seems you are correct about the preset units being regional. I set all units to mm and still the presets in the Print section show up in points and pixels. Probably has to do with the initial AI install ? I never see this as I never use the Home screen- I have set in Preferences> General uncheck Show Home Screen when no Documents are open- and checked Use Legacy file "File New" interface. I really do not like the whole home screen thing. And @AnFa, this may be a solution for you so that your Units stay in mm. Just don't use the presets
    – Kyle
    Commented May 1, 2022 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.