0

As you can see in the picture, there's a thin black line between the red and turquoise objects, which are overlapping. Possibly due to antialiasing. I've tried modifying AA settings, with no results. Separating the shapes doesn't work either.

Would someone know how to fix this ? Thank you !

enter image description here

3
  • Are you exporting this as a raster image? If so, there's probably not much you can do TBH. If you were to remove anti-aliasing, the edges would be jagged, which would probably be worse. Make sure you are viewing the raster image at 100%. It should be less noticeable.
    – Billy Kerr
    Jun 23 at 11:45
  • This rendering artefact is called ringing, name comes from audio processing you might have heard it. It is possible it isnt but without a file construction i cant say for sure. Most likely it is you can remove this partially by doing physically correct color blending by making a linarized sRGB space or by rendering elsewhere
    – joojaa
    Jun 23 at 17:07
  • Make the green shape go underneath the red and yellow a bit. Don't align them perfectly at those edges.
    – Scott
    Jun 23 at 20:08

2 Answers 2

1

I'm sure it's anti-aliasing which generates without asking blend between your red and green in such a way that the antialising zone is darker than colors around it. You can make the blending happen so that the result is less offensive. An example:

enter image description here

In the left there's 2 rectangles with your red and green. The image is rasterized to low resolution to make the dark antialiasing zone well visible.

In the middle there's the same rectangles as vector. The green one has got a narrow stroke which is the same green, but desaturated. Desaturating is easy in the colors panel HSB mode.

In the right the vector version is rasterized. The antialiasing zone is not darker than the rest of the shapes.

If you are not going to rasterize anything, know that rendering your image just to show it on a display does it without asking. But a grey stroke, thin enough and as bright as the green area fixes the dirtiness also in that case. Draw it with the Pen as a separate path to limit it on the red area.

You can find older cases where automatic blending between colors creates an unwanted dark zone. The fundamental math reason for it is the the non-linear gamma of the ordinary sRGB color space. The problem is non-existent if one uses either some linear gamma version of RGB color space or selects in his image settings option "make blendings in a linear gamma RGB color space". Unfortunately my ancient Illustrator offer none of these. But here's one discussion of it for Krita: How to get rid of weird black borders in Krita?

0

Kindly check 'opacity' and 'Blending modes'. Set the blending mode into 'Normal'. Yours one is set to 'Multiply'.

Thank you.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.