0

action here is the action

enter image description here here is the batch

image processor here is the image processor

Image Processor and Batch is not working with an action that work normally.

The batch just simply do the right actions, I can see them on my screen, but it saves none of them. Image Processor simply errors out saying: error

This was all supposed to open a picture, copy it, open a mockup, edit the smart object, paste the picture, save and close the smart object, then save the final image.

Here is my mockup: https://drive.google.com/file/d/1uIRSc5IoMTEOYtPRSXnIqQsEefESYOhY/view?usp=sharing

6
  • What exactly are you trying to achieve here? I've been looking at your screenshots, but I haven't tried to replicate. It seems that you try to batch with a folder as destination, but what do you expect to end up in that folder? The action seems to open up the mockup file separately from the image been processed, alters the mockup and saves it. Then you overwrite the mockup file every time you run the action, but the file being processed is closed and can't be saved. And it wouldn't work even if you don't close it as it isn't altered.
    – Wolff
    Commented Jun 27, 2022 at 22:16
  • Could these PNG files be in the wrong colour mode? If a PNG is in Indexed colour for example, all the filters and many other functions won't work.
    – Billy Kerr
    Commented Jun 28, 2022 at 7:23
  • Hello @Wolff, thanks for your reply, I expect finished mockup images in the folder. I'm kind of confused, do you think there is anything else I can do to solve that? Or maybe an alternative? Also, before everything else, I tried to run the Image Processor with an action that looks exactly same with this one, it gave me an error but it did save the finished mockup images. That makes me even more confused.
    – pofdzm
    Commented Jun 28, 2022 at 13:31
  • Hello @BillyKerr, thanks for your reply, how do I see and change it? Also, is there a way to know the right colour mode?
    – pofdzm
    Commented Jun 28, 2022 at 13:32
  • Open one of the problematic images and then in the main menu do Image > Mode > and check what it is set to. You can change it there if necessary. RGB mode enables all functionality. Note: This is just a guess though, there might be another problem somewhere else. It's hard to tell without access to the files and your setup.
    – Billy Kerr
    Commented Jun 28, 2022 at 14:34

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.