0

When I make a clipping path on an image in photoshop and save the workpath and thereafter duplicate the image from one psd to another psd file, then only that specific image layer is duplicated to the other psd file, the workpath is not duplicated. Now if I copy the workpath from source psd and paste it to the destination path layer, the path is not aligned with the exported image (clipping path).

Is there any option in photoshop so that the image can be duplicated along with its workpath from one psd to another?

1 Answer 1

1

A bit convoluted, but works....

Original file:

  • Select the work path via the Path Selection or Direct Selection Tool (White or Black arrow)
  • Choose Layer > New Fill Layer > Solid color.. (click OK then pick a color, any color - this is ultimately a temporary layer)
  • Highlight the new vector shape layer which was just created and the pixel layer it aligns with and duplicate/drag these two layers to the new file.

New file:

  • Highlight the Color Fill path in the Paths Panel and copy it by dragging it to the copy icon at the bottom of the panel.
  • This should create a new Path 1 path in the Paths Panel
  • Drag the Color Fill path to the trash icon on the Paths Panel to remove it (this will also remove the vector shape layer associated with it.)

Now you can highlight and designate Path 1 as a clipping path and it should still be aligned with the raster layer.


As far as I'm aware, there's no direct option to link a path with any raster layer (other than a vector mask). And the Path Panel offers no ability to copy/duplicate a path to another file, unlike layers.

However, you can drag a path from the Path Panel to another document and the path should remain in the same relative location:

enter image description here

But position is only really maintained if both files are the same dimensions If the two files are different dimensions, the path gets centered within the document when it's dropped. The centering of the path may or may not be an issue depending upon the files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.