1

This seemed like a futile thing to look up but every single guide I check seems to work for a different use case. My question is this: given a "prism" (or just an extruded rectangle), how can I outline it with a thin black line? Below, I attempt to apply a stroke but it just changes the entire outer 3D edges. enter image description here enter image description here

What I actually want is this (made in PowerPoint):

enter image description here

How can I do this in illustrator?

0

1 Answer 1

2

2 options...

Option 1

You need to use the classic 3D effect, the new 3D architecture in recent versions of AI all result in pixel-based artwork.

  • Choose Object > Group from the menu (even if it's only 1 object)
  • Add a New Stroke in the Appearance Panel at the Group level. Just be certain the stroke is above the <Contents> listed in the panel.

enter image description here

Option 2

Use Object > Expand Appearance from the menu — but the 3D effect will no longer be "live" and editable after doing so. You can then select individual pieces and alter their appearance as desired.

8
  • Thanks for your quick reply. Unfortunately, the first option doesn't seem to do anything at all. If I make the group stroke 1 pt or 100 pt the object appears the same. For option 2, how exactly do I select individual pieces? No matter how much I click around with either selection tool nothing happens. Thanks again.
    – jhschwartz
    Jul 4 at 1:58
  • The first option should work without issue. Check the stack order of things in the Appearance Panel. You have to create the group, add a new stroke, make certain the stroke is above "contents" and it should work fine. And if you are "clicking around and nothing happens" there's something else taking place. Just a guess.. but try tapping the ESC key.. then try clicking.
    – Scott
    Jul 4 at 3:05
  • I'm not sure what I'm missing but it's just not working either way. Here are gifs of my two attempts, hopefully you see something I don't: Option one: ibb.co/6Rfxt2h Option two: ibb.co/sCQthbX
    – jhschwartz
    Jul 4 at 3:36
  • Okay.. first option may be a bug, but it may also be due to the CMYK color mode. Try it in an RGB document. I do notice some oddities here in CMYK (which I've never noticed before). Second option.. looks like it's expanding to a raster <image>. Not sure why, that may be due to the new 3D architecture.
    – Scott
    Jul 4 at 4:41
  • To be honest, based upon your gifs.. it looks like they've really messed up the 3D in the latest AI version. I'm purposefully a couple version back to avoid stuff like this. If you can't rely on the Appearance panel.. and can't expand without things resulting in a raster image, I'm afraid I'm a bit stumped regarding this then.
    – Scott
    Jul 4 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.