Sometimes I need to save the Photoshop files i'm working on as .pdf, but there is a huge problem with the .pdf export on my computer.

  • For example here is a brochure design draft. It looks great in Photoshop:

enter image description here

  • When i export the .psd to .pdf (with the Save as... command), the result looks like this:

enter image description here

The rasterized image layers are OK, but the vector objects (logo) and the texts... horrible. Has anyone met this problem?

  • no intention to sound sassy at all, but is using InDesign an option?
    – Vincent
    Feb 12, 2013 at 12:01
  • What are you viewing the PDF in? Preview? What's the PDf look like in Reader or Acrobat? Preview has some serious rendering bugs where PDFs are concerned.
    – Scott
    Feb 12, 2013 at 15:07
  • i am having the exact same problem ... black vector text rendering white. randomly. any further developments on a fix for this?
    – user10239
    Feb 22, 2013 at 20:23
  • 1
    seems like a bug to me. I have the exact same problem. I'm glad someone suggested the rasterize text idea. I have been battling this thing for a while now. ADOBE we need a fix for this!
    – user12839
    May 20, 2013 at 20:05
  • This issue persists for me in PS CC 2014.
    – user57563
    Oct 13, 2016 at 4:24

8 Answers 8


This is a known bug with Photoshop CS6 IF you ran any updates. In other words, a fresh install of CS6 doesn't have the problem - an version other than 13.0 WILL have the problem. There is no fix yet, and there is no way around it.

The problem only occurs on Photoshop documents with text blocks with more than six lines of text exported as a PDF (with any settings combination).


Here's the workaround for Mac (might also work for PC, not sure):

  • Cmd+P (print)
  • Make sure you have Scale to Fit Media checked
  • Click Print
  • In system print dialogue, click PDF dropdown and choose Save as PDF

This is not a permanent fix, but it might get you on your way until you find one.

You could create an action that converts all layers to raster then saves out a pdf, then undo's the raster changes.

This way you get the pdf looking as required and your still working non destructively - I would recommend saving a copy before doing this on large files - just in case.


I have run into the same issue when exporting .pdfs in InDesign for print. The solution we found to work best is if you print the design. It will embed the fonts and in InDesign it will preserve all white pages. I know you said Photoshop but it would be something I would try. Hope it helps.

here is another option to try


The first place i would look is the transparency flattening option in the PDF dialogue since this in known for causing problems with drop shadows.


Maybe you could try importing you file in Illustrator before exporting as PDF. You will also convert your text layers in Photoshop to vector!

You can save your Photoshop file with the layers in .psd, and then open it in Adobe Illustrator.

You will be asked to select between changing the layers to objects or flattening the layers into one image. Choose "objects".

It might not work for your objects in Photoshop (unless they're already vectors I suppose) but it will make your text layers as vector!

Here is a question/answer about this with more details.


No workarounds for this, just hoping that Adobe will fix the bug. I'm using Retina display, so there is no option of downgrading to PS 13.0


You can play with the display settings in Adobe Reader (assuming that is how you are viewing it). I can't remember specifically which one was the cause (my guess is Page Display> Smooth Line Art), but this will affect how the vector lines and fonts appear when viewed.

Ultimately though, Photoshop is not good at exporting PDF. It creates file sizes that are about 10x the size they need to be. As suggested, you should use InDesign or Illustrator for PDF documents.

  • The reason Photoshop appears to be "not good at" exporting PDFs is only that a PDF which retains Photoshop editing capabilities consists of the PDF itself and the entire PSD "hidden" inside. Uncheck that option in the PDF dialog and the resulting PDF will be the same as any other. Mar 28, 2014 at 2:19
  • This is true, it looks like they improved things in (CS5?)/CS6/CC. Back in CS4, the flattened PDF's (without PS editing enabled) were still very bloated and the quality was poor. I used to have to take a PS design and place it in a ID document to get the PDF file size down. (I didn't have Acrobat/Distiller)
    – John
    Mar 28, 2014 at 13:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.