2

I haven't used ExtendScript for a while. Now I got a new laptop and just updated to the latest indesign-version CC2023. I wanted to debug an indesign-script so I had to set ExtendScript up again. I noticed there is a new version and my launch.json didn't work anymore.

I updated the launch.json to

"version": "0.2.0",
"configurations": [
    {
        "type": "extendscript-debug",
        "request": "launch",
        "name": "CC 23 Current Script",
        "script": "${file}",
        "hostAppSpecifier": "indesign-18.064",
        "engineName": "main"

But when I launch a script, nothing happens.

The debug menu is not showing anything wrong. It is connected to the CC 23. When I launch the debugging session the "jump, pause etc"-buttons appear for a second and the blue bar at the bottom switches to orange for the same second but nothing happened in indesign. It doens't matter which script I try, it's as if it's not connected to indesign at all. But it also doesn't show any error message.

enter image description here

Does anybody have an idea whats wrong here?

2
  • I have the exact same issue. Can't find any help online after much searching. Did you ever resolve this?
    – hedgehog90
    Jun 10, 2023 at 12:09
  • I'm sorry, It works now. I don't know why or how.
    – SabineR
    Jun 12, 2023 at 5:40

1 Answer 1

0

Some of the parameters in launch.json have changed. Here's what's working for me using Visual Studio Code 1.81.1 with InDesign 2023 v18.5:

"version": "0.2.0",
"configurations": [
    {
        "hostAppSpecifier" : "indesign",
        "engineName": "main",
        "type": "extendscript-debug",
        "request": "launch",
        "name": "Name of MYSCRIPT",
        "script": "${workspaceFolder}/MYSCRIPT.jsx",
    },

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.