I am creating a logo and have drawn a motif with the pen tool and - as far as I'm aware - the path is closed as I'm able to fill it with colour.

However, on closer inspection, the fill colour is not sticking to the path as the boundary, in fact it's either filling outside the path or within it.

The motif was initially a little crude so I used the smooth tool and I wonder if this has caused any issues. In one area it looks like the fill has glitched and there are little lines of white appearing along the path.

Does anyone know why this might be happening and how I can fix it? I have tried removing the fill and then replacing, and also tried some pathfinder options - uniting & merging but no luck.

enter image description here

  • 2
    Try this. Do View > CPU Preview to switch off GPU rendering. If that fixes the problem, then it must be a GPU rendering glitch. For a more permanent fix, try updating your graphics card driver.
    – Billy Kerr
    Oct 26, 2022 at 21:06
  • I'm assuming this is Illustrator? I can't think of any Smooth Tool or Pathfinder elsewhere. The "little white lines" would be a GPU issue as Billy suggests.. the fill not remaining within the path could be an Align to Pixel Grid issue.
    – Scott
    Oct 26, 2022 at 21:10
  • Sorry, forgot to mention it was in Illustrator! That’s great thank you both for your help. I will try this tonight and update you.
    – Laura
    Oct 27, 2022 at 7:35
  • Thank you guys. That advice worked a charm!
    – Laura
    Oct 28, 2022 at 11:22


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.