1

After much trying tutorials and googling how to remove the black outlines of text in Inkscape (I think it's the "stroke"), I have no luck. I would just like to make a few designs for different color t-shirts and the outlines are in my way, meaning I would just like to have the "fill" of the text to remain.

I would be very grateful for any help.

8
  • Hi. Welcome to GDSE. It depends how it was constructed. It could be a simple stroke, or it could be something more complex. Is it a vector image? Is it a raster image? It's difficult to say much more without seeing it. Can you share the SVG over at SVGshare.com and post the link here?
    – Billy Kerr
    Commented Jan 28, 2023 at 16:23
  • Thank you for the comment. I'm not really sure about the image types since I'm a beginner... Basically every letter in any font that I write has an outline of stroke around it, before i save and export it everytime. Is there any known way at all of getting rid of the outline that the fonts have in any case?
    – Luka
    Commented Jan 28, 2023 at 16:39
  • It sounds like you do have a stroke set on the text. Select the text box, then open the Fill and Stroke panel using Shift+Ctrl+F. You can change fills and strokes in there.
    – Billy Kerr
    Commented Jan 28, 2023 at 17:03
  • You can also go into Edit > Preferences > Tools > Text, and make sure to set the Style of New Objects as shown here. That way your text tool won't ever change its default style accidentally.
    – Billy Kerr
    Commented Jan 28, 2023 at 17:17
  • 1
    Thank you for all your help Billy Kerr! I managed to make it work. It seems like it is just a matter of setting the stroke paint to no paint aswell. You really helped me today! Thank you!
    – Luka
    Commented Jan 28, 2023 at 17:57

2 Answers 2

0

It sounds like you have a stroke set on your text. There are couple of ways to fix this.

Make sure the text box is selected, then open the Fill and Stroke Panel using Ctrl+Shift+F. This is where you can delete or change strokes and fills. Select the Stroke Paint tab. The X button on the left will delete the stroke completely. Similarly to change the fill, go into the fill tab.

enter image description here

You can also fix the problem with the Text Tool acting in unexpected ways. If you go into Edit > Preferences > Tools > Text, you can set the Style of New Objects setting to This tools own Style. This will mean the default will always be the same, so even if you set a stroke, the tool will return to its default next time you use it.

If the option in there has a stroke set, you can select some text that has no stroke and hit the button that says "Take from Selection". That will store it as the default.

enter image description here

1
  • It all works nicely... Thank you so much for your help! Sincerely.
    – Luka
    Commented Jan 29, 2023 at 12:28
0

This isn’t working for me, I’ve tried both and her I choose “union” for the text it hours from solid black to an outline!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.