5

This has been puzzling me for a few days now, and I asked a graphic designer I knew before trying here and haven't been able to solve it yet. It's quite weird so please bear with me for a bit.

I am using Adobe Illustrator to create a logo, and I have something that can potentially work. I have used only the pen tool with strokes (no fill), but the issue is, when I view the logo at 100%, it looks pixellated! I know vectors should not even be able to appear pixellated, but they are. Here is the screenshot from AI, without exporting to anything:

image

That was just done using the snipping tool within Windows, and it's at 100% zoom.

I have anti-aliasing turned on from Edit > Preferences > General, and the document resolution is at 300 ppi (I get the same result with 72 ppi).

Could anyone help me with this?

If relevant: Using CS6, and have a 24 inch Dell U2412M at 1920x1200 resolution. I do have a 21.6" Samsung at 1680x1050 and I get the same result there as well. Let me know if you need any other settings, or if you would like the file, I'd be happy to provide it to be able to solve this problem.

  • 2
    This is a limitation of your computer screen. – DA01 Feb 26 '13 at 3:27
  • 1
    If any of the answers below answers your question, please tick the "accepted"-tick-mark next to it, to mark it as the useful answers. StackExchange relies on this, and it is good for us all. If you did not get a good answer, perhaps edit your question to be more specific of what the problem is. – benteh Aug 19 '15 at 14:51
  • In my case the pixelated graphics was because of applied SVG:filter effect – when I turn it off, everything became smooth again. – Pavel Alexeev Mar 8 '17 at 20:29
13

Your monitor (or any monitor) uses pixels to display anything. It's not possible for you to see anything on a screen unless pixels are used to display it. This is where you are seeing the pixels. Until some company somewhere invents a monitor which uses vector data to display content, you will need to become accustomed to pixels in every image. I wouldn't hold my breath waiting for such a monitor.

Vector data is smoother than raster data upon scaling and output, not upon display. If you ensure anti-aliasing is checked in the AI preferences, that's the best you can do since the monitor is still using pixels. You should see smooth edges when printed for vector data. And if using Save for Web, or exporting, you will want to ensure you choose the "Art Optimized" anti-alias setting within Illustrator to reduce the stair stepping of pixels as much as possible.

A retina display or monitor with a higher pixel density would smooth the edges more even though the artwork hadn't been touched. There's absolutely nothing you can do within any application to improve the pixel density of your monitor.

In short, this is the nature of digital displays. You can't remove all pixel indications, because the display itself uses pixels. Better monitors will show them less, but they are still present, at least until some massive innovation in display technology.

  • Hey Scott, I appreciate the input. So you're saying that seeing that image with such high pixellation on the right side of the "O" is normal at 100% zoom? And it's also expected for the pixellation to disappear the more you zoom in? In short, does that AI screencapture look normal to you? – ozzyna Feb 20 '13 at 3:13
  • It looks normal for a monitor with a low pixel density. The Dell Untrasharps are okay monitor but they tend to have a pixel density of around 96ppi. Which isn't terrible, but it's not exactly "high" either. The stair stepping should not change regardless of zoom level. If it does, then you've got other issues going on. Perhaps pixel preview turned on in AI? Or some effect applied? – Scott Feb 20 '13 at 3:24
  • @ozzyna given the thickness of the lines you are using on the curve, yes that pixelation is normal and expected. The specific zoom level is not important. It is the relative size of the image at a given zoom level that is important. Zooming in increases the relative size of the image, decreasing the relative pixel size. So yes that screen shot accurately reflects what I would expect to see from a normal computer monitor given what you are displaying. – brnnnrsmssn Feb 25 '13 at 22:34
  • 1
    Scott, the underlying display paradigm is totally different from raster based video cards. Drawing single pixels with vector technology is even more ill-advised than drawing 'vectors' with raster pixel tech. Have you never seen an oscilloscope? Instead of the 'display matrix' used in RGB CRT screens, it contains finely grained phosphorus that lights up when stricken by a freely moving beam. The Vectrex was pretty awesome for its time. (Wikipedia sez it was monochrome as well. Another childhood illusion crushed.) – usr2564301 Jun 29 '15 at 22:42
  • 1
    Oh and I just had a blast lookin' at a YouTube video. I knew there were images with splashes of color. Talking about childhood illusions: it's just a colored piece of plastic in front of the black-and-white screen. (Also, the built-in game was not Tempest. Sigh.) – usr2564301 Jun 29 '15 at 23:07
5

Was searching this question out, and I know it is several years past now, but maybe someone else will be in the same shoes as I am.

This is the solution I found to work: Go to "Document Raster Effects Settings" in the Effect Menu. The resolution might be in 72, so change it to 300 (go ahead and tick the "Anti-alias" check box under "Options" while you're here). Then go to Edt > Preferences > General and click "Anti-aliased Artwork."

Another thing to note, if you are using effects on your artwork, try to make the image the size it will end up being. For instance, I was making a logo for a band backdrop, but it was only 10" x 15" when the final product was 10' x 15'. My understanding of vector was that it didn't matter, but it does, to an extent, when you are using effects.

Hope this helps someone else a little late to the party...I know it was driving me crazy.

NOTE: All my instructions refer to Illustrator CS6.

  • Welcome to the site, and thanks for posting what worked for you! We're happy to have new answers regardless of how old a question might be. – JohnB Aug 11 '15 at 22:22
  • this is good information in general. i did not include any information about anti-aliasing or types thereof when i originally answered the question. my reason for this was that anti-aliasing was not the issue he was having as he already had it turned on. – brnnnrsmssn Aug 29 '15 at 21:46
3

One thing Ozzyna didn't specify is if this logo is to be used primarily for print or for the web.

If it's for print, simply printing it to a laser printer or inkjet printer set to highest quality will confirm if the pixelation is in the art or in the output device (96ppi screen vs. 300ppi laser/inkjet).

If the hard copy output is visibly pixelated, something else is going on that we haven't addressed in our answers to you.

If it's primarily for screen, import the art into Photoshop at 2x or 4x final size and then scale it down in Photoshop, which does a great job of anti-aliasing (visually smoothing lines).

While Bicubic Downsampling is best for photographs, test them all when downsizing line art. Then File > Export to Web.

Compare a transparent image like a .gif or .png to one with a white background like .jpg - and be sure to use high to maximum JPEG quality when exporting.

  • I would go further and say that if this is for web, it should be specified in the company's style guide that this is NEVER to be displayed below a minimum size; and if it needs to be this small for a website, I would strongly reconsider the design itself, or at least make a simplified, secondary version. This is not an appropriate logotype for web at this size. There is no way to show a <1px stroke curve without antialiasing problems on a non-retina device, and letting the browser handle scale-down from retina size will be even worse. – joshstrike Dec 5 '14 at 19:11
  • Also be careful to not upscale too much when trying this method, because you might get artifacts when you ultimately downscale in Photoshop. For example, creating art at 72ppi in Illustrator, exporting the AI into Photoshop at 600, then downscaling back to 72... you may notice some auras or softness here and there (even though you're sizing down, you can still get undesired results). You may find better results if you go 72 > 300 > 72; less of a jump. – MarsAndBack Nov 25 '18 at 17:50
1

As Scott said the pixel size in your monitor is fixed so the pixelation caused by the limitations of the physical pixels is ever present. This pixelation is what you are seeing here.

However, when you zoom in the image is re-interpreted for the new display size. This results in more pixels inside the shape and thus they are smaller relative to the shape: and the edges of the shape appear smoother. Unlike magnifying a printed pixelated image the dots themselves do not get larger when you zoom in using Illustrator; causing an apparently smoother edge.

The cause behind the exaggerated pixelation in your image is the quality of your lines, namely thickness and sharpness. Due to how narrow the lines are compared to pixel size and how quickly they transition from full black to full white it is difficult to display them. When you zoom in even one step I assume you see a drastic improvement in appearance. This is because now there are that many more pixels to be used as explained above. If you were to soften the edges of the lines even a slight amount and thicken them as well you should be able to improve the edge quality.

A file with 300dpi is still limited by the display which it is viewed through. But a high density display will be able to take advantage of that extra information.

  • So if I understand correctly, the way to fix this issue is to increase line thickness (i.e. stroke) and increase the size of the logo (to accommodate for the increased thickness of stroke, otherwise things start merging prematurely, destroying the logo). Is that correct? If not, what would be your recommendation to fix this issue? Because when I go to "save for web" and export this into a png file, the pixellation is maintained and the logo looks to be of poor quality. Sorry for the persistent questions, I really appreciate the help! – ozzyna Feb 26 '13 at 1:38
  • Yes, if you are unwilling to manipulate the arrangement of the lines enough to accommodate the increased thickness you would need to increase its size. You said that zooming in on the image decreases or altogether eliminates the issue correct? Increasing its size will have the same effect as viewing it above 100% zoom. I understand the difficulty you would have in allowing yourself to rearrange the lines but this would be necessary to maintain the current size. To the audience such a change would be almost imperceptible. – brnnnrsmssn Feb 26 '13 at 1:54
  • You can also experiment with making the antialiasing crisper, by raising the contrast (or if this is still an unexpanded font face in illustrator, you can change the type of antialiasing in the type window). But that probably won't be enough for this... the lines are too thin and the space between them is too thin for a computer display. It would look just fine laser printed, though. – joshstrike Dec 5 '14 at 19:55
1

A lot of good factual information here. One other thing to try is making sure your art is aligned to the pixel grid. You can do this when creating a new document: - In the New Document window, click the arrow to open the "Advanced" settings. There's a checkbox for "Align New Objects to Pixel Grid".

Or, in your existing document: - Open the Transform palette (Shift-F8). Select all your artwork (Cmd-A), then click the very bottom check box "Align to Pixel Grid".

This will mainly help tighten up straight edges, not as much on curves. But still a good habit to get into when using Illustrator to design for web.

1

With CC 2015, you have two preview options.

Under View, you will see GPU Preview or Preview on CPU.

enter image description here

To see a crisp high-res version, use the GPU Preview and not the Preview on CPU

This makes your vectors appear crisp on screen and not pixelated. ;)

  • 1
    The question is also 2 years old though, @Kurt. This answer may help someone with newer versions of AI. – Manly Jun 29 '15 at 19:33
  • 1
    This really has nothing to do with the quality of the preview and this answer is completely incorrect. Whether the GPU or CPU are used only changes the speed at which things may preview. it doesn't change the underlying rendering code. The preview will look exactly the same using either processor one may simply be faster, that's all. – Scott Jun 29 '15 at 20:21
  • @Scott: the answer is not "completely incorrect" for the description provided in the initial question. Specifically, the switch between the CPU and GPU preview drastically altered the rendering for me (at least on a Surface Pro 4). When switching between the two preview modes, there was a significant difference on every file I opened. It wasn't until I disabled GPU Performance entirely in Preferences > GPU Performance ― a change I apparently didn't need to make on macOS ― that I was able to permanently see what I needed to see and the way I needed to see it. – Jason H. Feb 6 '18 at 13:55
1

in preferences, go to general and check "anti-aliased artwork"

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

0

go to View >

make sure the 'pixel preview' is off (unchecked)

0

go to View >

turn 'pixel preview' off (uncheck it)

  • Hi Kara, welcome to GD.SE :) This answer is pretty barren and, on this site, we do our best to provide detailed answers that will continue being helpful to others in the future. Please edit your answer and give a few more details. You can even add screenshots or link to examples. – Ashlee Palka Aug 20 '18 at 22:54
  • There's already another answer with the exact same content. Perhaps you should check the help center to learn more about how the site works – Luciano Aug 21 '18 at 11:33

protected by DᴀʀᴛʜVᴀᴅᴇʀ Dec 21 '15 at 15:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.