0

I have an old computer running macOS High Sierra (the latest available for that hardware) and Adobe Illustrator CS5 (yes, it's possible). I still use it because I purchased the software and this way I avoid the monthly creative cloud subscription.

I have documents using Open Sans and Open Sans Bold, and I installed the whole family from Google Fonts, but Open Sans Bold fails.

The font book shows Open Sans Bold, as well as others in the family, are installed:

screenshot showing installed fonts

But Illustrator only shows Open Sans Regular in the menu dropdown:

screenshot showing only Open Sans Regular installed

and no variations on that font:

screenshot showing no sub-fonts of Open Sans

and when I open a document with Open Sans Bold, I see:

screenshot with error

This only happens with Open Sans; I also added Amatic SC from Google and it shows Regular and Bold as sub-fonts. Initially, Open Sans Regular also failed to appear in Illustrator. I tried variations of quitting Illustrator, removing the font, restarting the computer, reinstalling the font, reinstalling only Regular or Bold, and starting Illustrator. It worked for Open Sans Regular but not for Open Sans Bold, neither by itself nor with Open Sans Regular.

Before I change all this text to another font, is there anything I could try to make Open Sans Bold work?

6
  • 2
    Tech support is off topic.. One should be aware that some tech issues are not solvable once the OS gets too far past App versions. Getting apps to "run" can be quite different from getting apps to "run without issues". Example.. CS6 apps ran perfectly fine, but started having some odd, noticeable, issues at Apple's Mojave. In any event, try clearing font caches.. community.adobe.com/t5/indesign-discussions/…
    – Scott
    Mar 20, 2023 at 19:18
  • @Scott I checked the link and inspected the installed fonts on ~/Library/Fonts. I saw only one file, with the whole family OpenSans-VariableFont_wdth,wght.ttf. I removed it from Font Book, then installed the individual fonts I needed: OpenSans-Bold.ttf, OpenSans-ExtraBold.ttfand OpenSans-Regular.ttf. I restarted Illustrator and now it works. Can you please write an answer and I'll accept it?
    – emonigma
    Mar 30, 2023 at 7:22
  • 1
    Truth is.. this is off topic. Supplying an answer merely encourages more off-topic questions. I realize you can't delete this now since someone responded (with what should have been a comment at most). Really, just let it go :) glad you got it sorted.
    – Scott
    Mar 30, 2023 at 8:25
  • Even off-topic, it was super helpful and saved me hours in converting text from one font to another. What would be a better place to ask something like this in the future? The Graphic Design chat on StackExchange?
    – emonigma
    Mar 30, 2023 at 10:24
  • 1
    Yes. Chat would be an excellent place to ask something like this. Or SuperUser.com
    – Scott
    Mar 30, 2023 at 16:00

1 Answer 1

1

I suspect the font type is the culprit. If you are using TrueType, try Open Type versions, maybe that would help.

1
  • Yes, I was using TrueType (.ttf). In any case, Scott's solution worked first and it's now fixed.
    – emonigma
    Mar 30, 2023 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.